Prior to El Capitan, it was possible to force emptying of the Trash when stubborn or "in use" items prevented it with "Secure Empty Trash". This option has however been removed in El Capitan.

How do I force the Trash to empty on El Capitan?

  • I'm not entirely sure where the 'Secure Empty Trash' = force empty? It doesn't help with overriding files currently in use…? – grg Oct 4 '15 at 13:47
  • 1
    Not =, but it was (almost always) possible to accomplish an empty when nothing else world work. What do you mean by "force empty"? – orome Oct 4 '15 at 13:50
  • 1
    @grgarside Secure Empty Trash would delete items that were in use. That's pretty much the only reason I ever used it. Finder (or whatever app) would lose track of if a file was in use, I'd be certain the file was no longer in use, so I'd secure empty trash rather than opening terminal and fiddling. – dwightk Oct 29 '15 at 17:36
  • Secure empty trash = delete the inodes in the filesystem and also write random bits in the file area so that they can't be recovered. It is not really force empty trash. I don't remember one such ever existing (force empty) in OSX. – Vikram Rao Dec 1 '16 at 16:21
up vote 16 down vote accepted

If you select an item or items and click on the “File” menu, there’s a “Move to Trash” choice; however, if you hold down the Option key with that “File” menu open, “Move to Trash” will switch to “Delete Immediately....”

This also works with files already in the Trash.

You can use 'rm' with the '-f' option:

sudo rm -rf ~/.Trash /Volumes/*/.Trashes

Be very careful if you manually type this in.

This empties the trash in your home folder and any trash on any other mounted partitions.

  • Is there no other way other than rm -f? – orome Oct 4 '15 at 13:51
  • @raxacoricofallapatorius It depends on what's keeping the files open I suppose and which of the several trash folders is causing the hangup. – bmike Oct 30 '15 at 20:00
  • I wouldn't run this. It also deletes the .Trash directory and I had some apps complain that they can't move files to the trash after running something like this. – bfred.it Oct 9 '16 at 11:05
  • for me: cd ~/.Trash; rm -rf * – AbdulMomen عبدالمؤمن Jan 31 '17 at 7:30
  • @Abdul That's an extremely bad idea. If the cd doesn't work, rm will still execute and delete everything in the current directory. If you want to delete contents, use rm -rf ~/.Trash/*. – grg Jan 31 '17 at 8:19

If you open the trash and right click on the offending file there is a "Delete Immediately…" option.

It is not as simple as the old "Secure Empty Trash" in the Finder menu, but it gets the job done without using the terminal.

  • 1
    or just cmd+option delete it – y3sh Dec 7 '15 at 22:17

Logging out of your user is a good first step to make sure it's not simply a user file still open.

Restarting will clear the open file lock in almost all situations. If you still can't empty trash, you'll want to look at the files in the trash or repair the catalog/filesystem if that's the root cause of some file not closing when moved into the trash areas.

I have the same frustrating problem and tried numerous methods that I could find from the web. However, nothing seemed to work until I did -

sudo rm -rf ~/.Trash /Volumes/*/.Trashes 

It really did the magic and the stubborn files (old time machine backups from an external hard disk) were finally deleted from Trash. It still took some time, but it did the magic at least. Thanks for the answer.

I had the problem of a file that got in to the trash would not be emptied. Delete Immediately also didn't work on it. Restarting the Mac did not resolve the problem.

I tried restarting in Safe Mode. The trash was empty.

Turns out the files that wouldn't empty were on an external FAT32 drive with some corruption. This drive wouldn't appear on Safe Mode and so the trash appears empty.

I don't have a PC to connect to and see if Windows can empty the trash. So I'll probably move the good contents from the FAT32 partition and format it.

I experienced this frustrating problem. Persistent folders & files that would not empty from Trash. The folders/files were protected somehow and when I tried to change read/write permissions, I got a message saying I didn't have the "necessary permission." I didn't want to do anything as radical as a fresh install.

Finally I came across this guide to disabling SIP: http://osxdaily.com/2015/10/05/disable-rootless-system-integrity-protection-mac-os-x/

I disabled SIP, emptied my Trash in the usual, normal way (it worked), and then re-enabled SIP.

Problem solved.

  • Disabling SIP is not under consideration, – orome Nov 18 '15 at 0:18

protected by Community Mar 15 '16 at 22:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.