0

I am using the iPhone Configuration Utility 3.3 and I had an iPad plugged in - while trying to deploy a profile, the application just crashed.

After this, I attempted to launch it several times but it would just crash immediately.

I looked through the ipcu.log file and saw that it had problems with a cryptographic key. I used Microsoft/Sysinternals Process Monitor and tracked down the key it tried to open and deleted it.

After doing this, I reopened the utility and it recreated a key and launched fine.

From here, I can create profiles, but when I try to install them on a device, nothing happens at all on the device, but going in to the console view, I see the device reporting this:

Mon Aug  8 11:41:52 wils-iPod mc_mobile_tunnel[341] <Warning>: MC|mc_mobile_tunnel starting.
Mon Aug  8 11:41:52 wils-iPod profiled[313] <Warning>: MC|Failed to parse profile data. Error: NSError 0x116640:
Desc   : Invalid Profile
US Desc: Invalid Profile
Domain : MCProfileErrorDomain
Code   : 1000
Type   : MCFatalError
Mon Aug  8 11:41:52 wils-iPod profiled[313] <Warning>: MC|Profile cannot be queued for installation. Error: NSError 0x112690:
Desc   : Invalid Profile
Sugg   : Invalid Profile
US Desc: Invalid Profile
US Sugg: Invalid Profile
Domain : MCInstallationErrorDomain
Code   : 4000
Type   : MCFatalError
...Underlying error:
NSError 0x116640:
Desc   : Invalid Profile
US Desc: Invalid Profile
Domain : MCProfileErrorDomain
Code   : 1000
Type   : MCFatalError
Mon Aug  8 11:41:52 wils-iPod mc_mobile_tunnel[341] <Warning>: MC|mc_mobile_tunnel shutting down.

I have Googled for ages and seen other people suggesting deleting various folders including the iPhone Configuration Tools Cache, Device and other folders, but I have had no luck whatsoever.

I have run this tool on another machine with the same device and configuration profile and it works just fine. This is just on this one machine.

I have tried reinstalling without any luck and cannot find the file that it is trying to load. Based on the invalid profile warning, I have a hunch that it is still something related to cryptography/keys and profile signing, but, I just can't find it.

1
  • I can't create tags - This is on a Ipod, but it affects everything I<device>... Can someone create a tag for the configuration utility as that is what the error is specifically with?
    – wilhil
    Aug 8 '11 at 15:27
1

I figured out that reinstalling the profile file into iOS Configuration Utility fixed it for me so probably make copies.

1
  • 3
    Make copies of what? Could you please expand and clarify your answer?
    – Cajunluke
    Mar 5 '12 at 22:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .