I have extremely high CPU time for Finder use after updating to El Capitan version 10.11.0

I've tried:

  • Rebooting the Mac
  • Resetting SMC
  • Resetting NVRAM

The machine is borderline unusable with 100% CPU usage taken by Finder.

What can rein this in or diagnose the issue?


Looking at this Apple forum thread, the first solution was this:

A first guess is: bad com.apple.finder.plist file in ~/Library/Preferences/. Delete the file.

Here was another that seemed to help:

I solved this issue by setting my finder preferences for "New Finder window show:" to my home folder... My issue was that it was defaulting to "All My Files"--- that caused finder to scan everything, images, thumbnails, etc and get up over 100% of cpu usage.

  • 1
    I'm a big fan of not using "All My Files" as well whether you have CPU usage high or CPU usage low. Good ideas! – bmike Oct 3 '15 at 22:37
  • Thank you, but unfortunately I saw it already and wrote about that link in my comments of question you can see. So, first idea doesn't make sense because I do not have com.apple.finder.plist and /Library/Preferences/ I don't know why. Second idea do not affected. – Maxim Tsybanov Oct 4 '15 at 21:41
  • 1
    @MaximDroy ~/Library is a hidden folder on Mac, so you can't see it unless you change your settings. There's now a special setting just for showing the library folder. In Finder, when looking at your Home (~) directory, choose view->show view options and check "Show Library Folder". – Theodore Murdock Oct 15 '15 at 0:44

I would like to let know everybody that I wrote to Apple Bug Report and they answered me... they said that they know about this bug and closed my duplicated report. We should wait a patch.

  • 2
    Way to go. Can you ask Apple what build includes 22539260? Also be sure to ask if it was closed with a code fix or if it was closed as no action/works as designed. – bmike Oct 12 '15 at 14:04

The cause could be lots and lots of things. Let's first narrow down some items. Open Activity Monitor and check other tasks, check memory pressure then disconnect from the network. (That last step helps isolate the system).

  • Reboot and check Activity Monitor again. Is it worse or better on RAM and CPU. Also consider snapping a picture so you see all the items using CPU and show all processes.
  • Make a new user account, log out of your user and in to the new user. Note if CPU is better or worse.
  • Reboot into safe mode (hold shift when you hear the startup chime) - this eliminates some software and all third party plug-ins.

enter image description here

  • 2
    Thank you. After several days of problem I understood that it happens time by time. Usually in evening (I don't know connect it with problem or not). So if I try to make a new user account I should work several days under new account what I can't do right now, I'll try it later. As I said before: reboot, SMC, PRAM reset doesn't make sense. Also I entered in safe mode for use "First aid" function of "Disk utility" and it doesn't affected too. But in safe mode impossible work, every graphical operations is so slow: new windows, hide or show window, so it is impossible to check this out – Maxim Tsybanov Oct 4 '15 at 21:47

Quit Pathfinder if you have it installed and running.

After upgrading to El Capitan I had the same problem. Finder CPU usage climbs quickly to ~110% when Pathfinder is running. No CPU issue if Pathfinder is stopped. Waiting for El Capitan support for Pathfinder from Cocoatech.

  • PathFinder seemed to be the culprit for me... AppTamer shows 27% instead of 75-95% now. – user150264 Oct 4 '15 at 8:28
  • 1
    Thank you, but I do not have a PathFinder. – Maxim Tsybanov Oct 4 '15 at 21:41

The problem appears to not be limited to specific apps. Personally, I often see Finder using 100% cpu, but Matlab, Lyx, Chrome and other programs have displayed similar behavior, although not as often. This indicates that it might be related to accessing the hdd or navigating the file system generally. I know that El Capitan has changed something about how programs are allowed to access system folders because it has forced a fundamental change in how LaTeX works.


I've isolated the problem that when I am connected to WiFi or Ethernet the CPU becomes overwhelmed. I'm running El Capitan just now and testing with no apps launched, all third party background apps killed in activity monitor. Just bare system with Ethernet now back running. My CPU seems to be stable now at 95% idle.I will methodically add back the system to see if I can determine the culprit. My advice is to first disconnect from the network, restart, and see if CPU stabilizes……then you can troubleshoot from there.


For me the solution was turning off "Calculate all sizes" in Finder; the setting that lets you show how big folders are. This instantly dropped the CPU usage without needing a restart. I had no luck with deleting the Finder plist and I didn't get round to resetting the SMC or PRAM.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .