1

I did a full backup before installing El Capitan, so a restore is available if nothing else.

After the install, I was able to login, but found that the login group for my non-admin account had been changed from staff (20) to wheel (0).

Looked around for a way to fix it and could not find anything but chfn. I suspected that would only affect files in /etc and not LDAP, but tried it anyway. 'id' showed it worked, but access to apps was not restored. Logged out, and could not log in. Account still shows in login screen but password gets the "headshake" signal.

Logged in to admin account, unlocked the users pref pane, selected the account, put in the password again, and then tried 'id wgroleau' in Terminal. "No such user"

The account is still shown on the login screen and the pref pane, but trying to reference it in terminal with various commands gets "no such user."

Any fix other then restoring Yosemite?

  • For the record, I spelled El Capitán correctly; Apple spelled it wrong. – WGroleau Oct 4 '15 at 23:33
1

Here's one way to fix (but I hope there's a better way):

  1. In admin account,

    sudo (cd /Users; tar cf )

  2. In Users pref pane, delete the account and the directory. (Trying to keep the directory got an error and did not delete account)

  3. Re-create the account. Verify in Terminal that the numeric ID is the same.

  4. Restore the directory contents from the tarball.

  5. If necessary, use chown/chgrp/chmod to fix metadata.

I also hope (too late for me) that someone can explain how it could have been prevented.

  • Well, I wish there were a better way, but apparently this is it. – WGroleau Oct 8 '15 at 2:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .