12

How do I display the WiFi symbol when connected to WiFi? iOS 8 used to show the WiFi symbol in place of LTE when connected to WiFi. Now, after the iOS 9 update, it always display LTE, even though I'm connected to WiFi. It shows I'm connected to my router in settings, and I also pinged my local router with a ping app.

iPhone 5, iOS 9.0.1.

  • 1
    If it isn't off already, try turning off Wi-Fi Assist at the bottom of Settings > Cellular. The behavior you describe doesn't seem normal, and it may not help, but it's worth a shot. – 0942v8653 Oct 2 '15 at 23:22
  • I tried that, but it still showed LTE. – Chloe Oct 2 '15 at 23:27
  • Sounds like a bug; have you tried backing up and restoring from scratch? (But only after backing up, and making sure you backed up. Did I mention to backup first? ;-) – Brian M. Oct 3 '15 at 2:17
  • 1
    I see the same thing, especially after it's been on for a few days. Turning it on and off fixes it but it's probably a bug – lc. Nov 10 '15 at 15:35
6

It should show up so the fact that it doesn't indicates a problem. In the past, Apple has focused on reliability for newer models and then subsequently released a X.1 version with under-the-hood work done for older devices. So it wouldn't surprise me if it is a deeper problem.

Two simple things to try right off would be a hard reboot of the device if you haven't already. You can do that by holding the home and power button down until you see the Apple logo. Also, make sure that you are on the latest version of iOS. iOS 9.0.2 is out now, so update and hopefully that will solve your issue.

If that doesn't work, you have to take it up a notch. You could try resetting all preferences to see if that solves the problem. Go to Settings - General - Reset - Erase all Settings to perform that function. If that doesn't work, the other main thing to try would be to restore the phone. Make sure you have a backup (I always like to have two), wipe the device, then restore.

  • 2
    Thanks, that was it. I turned it off then on, and now it works! – Chloe Oct 3 '15 at 7:05
  • Rebooting solved the issue for me. I'm on ios 9.2.1 On iPhone 6S Plus. – Ali Almoullim Feb 19 '16 at 6:17
  • Off then on didn't work. Restart didn't work. Soft reset didn't work. For me, 'Reset All Settings' did the trick. iOS10.0.2. Note that it is not 'Erase All Content and Settings'. That would have been my next choice. – oyalhi Oct 27 '16 at 14:21
  • This issue can also happen if you connect with USB to a Mac that has internet connection sharing turned on. iOS will turn off the wifi icon, which can leave you with the impression that your cellular data is being used, when it isn't! – Kevin Laity Apr 3 '17 at 16:30
0

It seems like soft resetting the iPhone is the only way to restore the symbol. I have an iPhone 5 too, and also have this problem.

I am able to connect to the router and can even browse the internet with my data service disabled from my carrier's end, but it still shows up as 3g or lte in place of the wifi symbol.

As stated before, the wifi assist which is turned on by default was turned off by me.

Might try a reset but not sure if I want to put that much effort into this. It appears to be using wifi data rather than cell data after all. It's just confusing to know which I'm connected to at a glance without going into the settings ño double check every time.

  • Just turn it off & on. – Chloe Oct 22 '15 at 19:41
-1

A hard reset worked for me. I was not showing the icon on 5S but wifi was working.

  • You don't have to reset it. Just turn it off & on. – Chloe Nov 7 '15 at 19:50

You must log in to answer this question.

protected by Community Nov 17 '15 at 10:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .