After a few days of using El Capitan I decided to do a clean install today.
As always I backed up ~/Library/Mail and put it back after the clean install.

When I opened Mail after that, there were no accounts, no local mailboxes, no mail!

Since the I tried to restore every file that could be associated with Mail I could find from a TimeMachine backup:

~/Library/Mail
~/Library/Containers/com.apple.mail
~/Library/Preferences/com.apple.mail-shared.plist

Nothing has changed from that.


My Mails and Mailboxes are located in:

~/Library/Mail/V3

My Accounts are stored in the only file left in V2:

~/Library/Mail/V2/MailData/Accounts.plist

But Mail seems to ignore the whole ~/Library/Mail folder. Any ideas what I could do?

  • Welcome to Ask Different. If you want to ask a jeopardy style question- that's great! Be sure to put your answer in the answer section and then edit the question down to the bare minimum. Long answers are great, long questions get closed or deleted generally if they can't be edited down. – bmike Oct 3 '15 at 13:58
  • Thanks for the welcome. The problem with this question is, that my I solved it might be an answer, but a terrible one. I would love to see anyone come up with a better solution. If I make that my own answer it seems like the problem is resolved when, in reality, it is not … – Afterlame Oct 3 '15 at 14:42
  • That's not how the site works. We don't delete wrong answers. You choose to mark an answer as accepted, so everyone knows exactly if you have a solution. You can even change your mind on the accepted answer anytime you want. – bmike Oct 3 '15 at 14:45
  • okay, I will make my solution an answer then. – Afterlame Oct 3 '15 at 14:46
up vote 2 down vote accepted

I decided to restore my mails by hand. That took me a few hours, but now I am back to normal.

Here is what I did:

  1. Import every local mailbox from the backup
  2. Clean up the mail boxes (Cryptic folders were generated inside every mailbox)
  3. Add the POP accounts.
  4. Write mails from there to get a dedicated "send" folder for each account.
  5. Put the imported mails in the appropriate location (inbox, drafts, sent)
  6. Add the IMAP accounts.

What I realized after going through all those steps, is that the accounts inside of ~/Library/Mail/V3 are not named by there account names anymore. Instead the consist of a cryptic combination of numbers and characters. Maybe that was the cause why Mail did not import anything.

My guess is, that accounts are now referenced by a number/character-code out of security reasons. However, that leaves me wondering how to do a proper backup of mail for a clean install.

What you should do is go to the V3 folder go to Maildata.Open the folder and remove all items except for syncedrules.plist Than close mail and reopen it. Next it should start importing all your mail folders and boxes.

  • Nope, did not work :( After restarting it just shows me a "Create a Account" dialog. But it does create some files in the Maildata folder. But not a Account.plist file – velop Nov 6 '15 at 10:31

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.