1

Whenever I send someone a text, I'm told that it shows that "myname@icloud.com" is sending the text and not my phone number. And when someone responds to "myname@icloud.com", I receive the message on my computer and Wi-Fi only iPad, but not my iPhone. Is there any way to only send and receive messages from a phone number?

I've done what it says on the forum to go to settings, messages, send and receive then it just says me emails and my number is just spinning it doesn't give me any other options.

  • How are you sending the text? – Mark Oct 3 '15 at 14:21
2

On your iPhone, turn iMessage off and back on and wait for activation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .