20

I'm running into an issue where keychain password verification box does not verify password - does not shake for incorrect password and nothing happens when I press "allow". I'm using iCloud keychain.

What could make the Keychain Access wants to... dialog box to not verify the password?

Nothing happens when I press "Allow" with password enters. The box does not shake when password is incorrect: enter image description here

  • 1
    I have the exact same problem :( anyone? – Gamer Oct 4 '15 at 7:44
  • 2
    Related: stackoverflow.com/q/33311873/1214800 OMG I want to smash things! – brandonscript Oct 26 '15 at 19:07
  • I came across this issue as well, it turned out that I had to disconnect my Wacom Tablet, and use a regular mouse (Magic Mouse in my case) in order for the 'allow' or 'always allow' buttons to work. Such a weird bug to diagnose. Luckily I didn't have to turn off any of the apps in the Settings -> Security -> Accessibility area. – Anil Natha Jan 4 '16 at 3:38
  • 1
    This issue is caused by a new Apple restriction on Keychain whereby scripts and apps will no longer have remote access to Keychain functions like export. I would have left this as an answer, but this thread has been protected from spammy answers that contribute no worth to the question – jcpennypincher Feb 10 '16 at 0:07
18

I encountered this same issue today. I could not "Allow" or "Always Allow" any programs, nor could I confirm my password in any dialogues. The interface wouldn't shake, even if I had entered the incorrect password.

I use Synergy to facilitate programming over several different computers. My mouse and keyboard do not belong to the Mac OSX device. I was able to hit the "Allow" button once I used a mouse actually hooked up the Mac OSX device.

In general, try turning off any virtual or physical KVM services and use the Mac mouse/keyboard directly.

Hopefully this can help you or someone else who comes here looking for help.

  • I found with Remote Desktop running, having a mouse connected (and watching on the nearby remote screen) still exhibits the problem. Even connecting a screen and keyboard while remote desktop is observing presented the issue. I removed remote desktop and tried from VNC - same problem. However, having VNC running, and accessing from the local installed keyboard is OK. This sucks! – Jasper Blues Nov 5 '15 at 9:34
  • 8
    @BobChao87's answer is right. I had same problem when MagicPrefs program (used to customize experience of Apple Magic Mouse) was launched. If you're using MagicPrefs, simply quit this program and everything will work well. – Kirk Hammett Nov 9 '15 at 12:24
  • 1
    @Behdad I think, we may contact MagicPrefs directly to ask if they can warn users about this problem. UPD: contacted developers regarding this question. – Kirk Hammett Nov 16 '15 at 13:56
  • 1
    Bless you @KirkHammett for saving me from sheer madness! – SaxDaddy Feb 12 '16 at 19:03
  • 1
    @KirkHammett I have MagicPrefs and it wouldn't allow me to 'Allow', nor with the touchPad, nor with the external mouse. But hitting <enter> without moving the mouse worked – codrut Apr 7 '16 at 11:53
3

For me, I had to go to System Preferences -> Security & Privacy -> Privacy.

On the left, click on Accessibility, then on the right side uncheck every checkbox. This resolves the problem. For me, I had Steam (from VALVe) running and Karabiner (keyboard key editor) which also was allowed to control the computer.

  • That's odd. I have a bunch of items in this privacy section yet my keychain is still filly functional. Are you able to detect a console error message showing what is logged when the bad extensions are enabled? I have eight enabled apps to control and one disabled. Of course, when I remote control this mac - that breaks keychain for "security reasons" - but not all apps in Accessibility seem to cause keychain to prevent synthetic actions. – bmike Jan 15 '16 at 15:56
  • 1
    I couldn't find any console errors. Steam seems to be the problem but I wasn't able to confirm it. – Steve Tauber Jan 15 '16 at 16:40
  • +1 This solved it for me. Thanks! Dropbox was one of the programs in that list for me. – JasonSmith Feb 3 '16 at 16:17
2

Just got this fixed. I use a plugin called SmoothMouse that improves acceleration of trackpad and mouse. It likely integrates with the accessibility APIs in OS X and thus triggers the same behavior as screensharing. Disabling the plugin resolved the problem.

You can see the sister StackOverflow question here as well.

  • 2
    I was having the same problem using a Wacom tablet with El Capitan. Disconnecting the tablet allowed me to export my certificates. – MiKL Nov 25 '15 at 8:39
  • @MiKL, I had the same issue, through testing various harward configurations came to the realization that my Wacom tablet was the issue. :/ – Anil Natha Jan 4 '16 at 3:39
  • I also tried installing the latest drivers from the Wacom site, but that did not resolve the issue. :( – Anil Natha Jan 4 '16 at 4:03
  • I confirm this appears to have resolved my issues. I was using MagicPrefs and when I quit it is too resolved the unable to press Allow. (I could use <space> to press Allow but never the mouse or the Always Allow. Deny always worked. – cgseller Feb 26 '16 at 15:11

You must log in to answer this question.

protected by Community Nov 9 '15 at 10:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .