12

How do I change the keyboard shortcut for highlighting text in Preview (OS X Yosemite)? By default it is Ctrl+Command+H, but I'd prefer a different combination (maybe Ctrl+E) as that’s easier to use. However, the following method does not work. How do I resolve this?

Tried adding keyboard shortcut through system preferences

  • How about adding this shortcut to Preview only not all apps? – Mateusz Szlosek Oct 2 '15 at 12:28
  • @MateuszSzlosek - very strangely, that doesn't appear to work in this particular instance; though it's a method I've used a lot, across many different apps. See my answer for more info. – Tetsujin Oct 3 '15 at 12:46
  • @Tetsujin I have different language in my OS and I thought that menu item is called "Annotate Highlight Text" ;) – Mateusz Szlosek Oct 3 '15 at 12:51
  • @MateuszSzlosek - ah, of course; if your own menu doesn't say the same thing, that would be impossible for you to have noticed. Could you check, though, whether it works as expected on your version, if you do add it as a Preview-only shortcut. It won't work here at all, even though the system-wide version does. – Tetsujin Oct 3 '15 at 12:53
  • @Tetsujin I have polish version of OS X (El Capitain Beta [15A279b]) and it works for Preview (I do not have to set it for all apps). I changed ⌘⌃H to ⌃E. (sorry for answering late, I was on my phone earlier). – Mateusz Szlosek Oct 3 '15 at 19:08
4

In OS X El Capitan 10.11.4 I was able to set up a custom shortcut like this:

  1. Open the Preview app.
  2. Enter Preview -> Services -> Services Preferences

    enter image description here

  3. Choose App Shortcuts

    enter image description here

  4. Click on the + button and the fill in the fields like below. It is important that the Menu Title perfectly matches the operation name to which you want to assign the shortcut.

    enter image description here

  5. Done. Now you can highlight text in Preview using your custom shortcut.

    works

  • This worked for me on MacOS Mojave. Thanks for very easy to follow instructions. – Yogesh Umesh Vaity Dec 28 '18 at 14:49
3

For nested menu items, separate the menu levels with -> without any spaces. You also have to include the top-level menu item. In this case that would be:

Tools->Annotate->Highlight Text

If Highlight Text is a unique menu item in Preview, you can also just use Highlight Text and omit the rest.

  • Any way to do this for specific colors? Like separate shortcuts for different colors? That's much needed. – TheOnlyAnil May 28 at 10:31
1

The error is that you've partly listed the hierarchy, though incorrectly. Normally, you don't need to specify the menu hierarchy at all - simply use 'Highlight Text' as your menu item.

You can use the hierarchy syntax, as mentioned in Arthur Hammer's answer - Tools->Annotate->Highlight Text - but unless there is potential for confusion, if the same command was present in two hierarchies, performing slightly different tasks, for instance, then there is no need.

Strangely, I cannot make any hotkey work if I specify that item for Preview only, as suggested in comments. Frankly, I have no idea why it would not work, as that would be the standard way to implement something like this.
Edit: This appears to have been a bug in that particular version of Preview & now works as expected.

Testing a similar sub-menu in Safari by adding Ctrl ⌃ E to Check Spelling While Typing works perfectly.

enter image description here

The workaround appears to be what you almost had - to enter it as a system-wide hotkey, then it works just fine.

enter image description here enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .