2

I have a MacBook Pro with retina display model A1502. I updated it to MacOS X El Capitan. The Wi-Fi connection is still not working. It works for sleep mode.

I followed this answer Wifi Keeps Dropping Macbook Pro 13in Retina Early 2015 but it is not working for me.

| improve this question | | | | |
  • To get correct answers rather than advice to read receipes to fix other problems, please describe your wireless environment (within your original question rather than comment). What is your wireless router? How far is it? On which channel is it running? How many wireless network from neighboors do you see from your MacBook Pro? – dan Oct 14 '15 at 7:24
  • If you can find another way to connect your MacBook Pro to the Internet, download the last free version of iStumbler: istumbler.net/archive/release99 , run it on your MacBook Pro configured on a Wi-Fi network configuration (even if it is failing). Make a screen capture of iStumbler, and insert it within your original question to get qualified answers. – dan Oct 14 '15 at 7:28
  • Within the question you followed and quoted, did you apply this one which is the best: apple.stackexchange.com/a/195367/22003 ? – dan Oct 14 '15 at 7:41
  • What did you try from the other posts? You should post a bounty on the existing question instead if none of them worked for you and you've the same issue. – kenorb Sep 14 '16 at 18:20
0

Exact the same issue. Only my MBP with El Capitan could not connect to wifi (always turn off and turn on to work for seconds), but just at home, not at office. I fixed with a firmware update of the router and access point (fritz!box), I also changed wifi radio channel and set wifi standard to n+g+b.

| improve this answer | | | | |

Not the answer you're looking for? Browse other questions tagged .