Does anyone know how to make symlinked services work in Lion? I used to keep all my services under version control in SL and symlinked into ~/Library/Services and this stopped working when I installed Lion. Once I 'installed' the services they work but even after they installed replacing them with the symlink doesn't work.

Anyone have any ideas to get this working? Or know why it no longer works?

I am using soft links if that makes a difference.

  • Is there a reason to not just hard link the file? ( I ask as I could see it maybe being a feature and not just a bug )
    – bmike
    Aug 8, 2011 at 14:46
  • I was under the impression one could not hard link directories. Is this incorrect? I just tried it and it wouldn't let me.
    – rjorgenson
    Aug 9, 2011 at 7:39
  • just hard link the file (or pick some CMS to automate the deployment of your files after a change. Radmind, chef, and puppet are some tools you could use if you don't want to roll your own using make.)
    – bmike
    Aug 9, 2011 at 13:01
  • 2
    Services are directories, not files. I went through and created a mirrored directory structure and hard linked just the files within the directory structure, and that worked. But defeats half the purpose of having hard links. Should I need to deploy those services on a new system it will be cumbersome. Why would soft linked files be disabled over hard linked files?
    – rjorgenson
    Aug 10, 2011 at 1:52
  • 1
    Is it possibly not the symlink that is the problem, but the permissions on the files? I know that launchd, for example, will reject files that seem excessively writable.
    – Kevin Reid
    Dec 10, 2011 at 18:07

1 Answer 1


I would hard link a file to make sure it's disabled by design.

You could then decide to go that path or come up with automation to deploy changes to production - something simple like make or rsync or complicated like Puppet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .