I upgraded my rMBP 15" (mid 2015) to El Capitan and suddenly my Ducky mechanical keyboard stopped working. The keyboard doesn't light up and upon viewing System Information, it shows Current required power = 0.

Anyone experiencing this issue too?

  • 1
    Yes, I have the same problem. I asked this on Apple Support Communities: discussions.apple.com/thread/7252288 In 10.11.1 beta 2 this isn't fixed yet, sadly. Oct 2, 2015 at 14:26
  • 1
    I have the same problem with my Kogan TKL with MX browns, however it shows as a "USB Keyboard" with current required power 100mA. Keyboard DOES light up, but no input is received.
    – Azz
    Oct 5, 2015 at 22:44

5 Answers 5


It's related to negotiating USB power requirements I think. I was able to use mine by running it through a powered USB hub.

  • My Ducky keyboard has the same problem. I just bought a Amazon powered USB hub, hoping it will solve the problem.
    – user150009
    Oct 2, 2015 at 23:53
  • Sadly, I didn't get my Ducky to work with a powered USB hub, which are you using @Zachary? Oct 3, 2015 at 8:37
  • I used two: the one built into my Dell U2414H and a Saitek 10 port USB hub Oct 3, 2015 at 13:53
  • Thanks, and which keyboard do you use, is it also a Ducky? Oct 4, 2015 at 10:17

There is a firmware update that fixes the issue. Contact support (support@duckychannel.com.tw) and they will send you the firmware. You need to apply it using Windows. But it works perfectly after that.


I found a fix for my keyboard (Kogan TenKeyless with Cherry MX Browns).

I tried USB Overdrive, which worked straight away without having to configure anything further.

There's a shareware version available which nags every time you start it, but if it makes my keyboard work again, I'm happy!


  • Thanks for the recommendation. Will try this one. None of the previously mentioned solutions worked for my Ducky keyboard as of the moment. Oct 28, 2015 at 5:56
  • Btw, since you just reminded me of this issue, I tried connecting my keyboard to a Macbook with an updated El Capitan (10.11.1) and it worked perfectly. Oct 28, 2015 at 6:04
  • Hmmm... I hadn't tried mine with 10.11.1 yet until after I installed USB Overdrive. Maybe it isn't required. Let me try it today and report back with how mine goes.
    – Azz
    Oct 28, 2015 at 21:44
  • Just adding here that my keyboard (Kogan Tenkeyless) did NOT work with 10.11.1, I still had to have USB Overdrive installed in order for it to work.
    – Azz
    Nov 3, 2015 at 0:56


newest firmware from ducky support:



I solved this problem by using Parallels Desktop

  1. unplug usb keyboard
  2. start parallels desktop vm
  3. plug usb keyboard again
  4. it will pop a window, choose the host that device want to connect to (choose vm here)
  5. keyboard should work in vm, and now shutdown vm
  6. keyboard now should work fine in mac

its only a workaround, keyboard will not work after reboot

Parallels Desktop

  • This doesn't work for my Kogan TKL with Browns. When connected to the VM it works inside the VM, but once I detach it, it no longer works (keys are lit up though)
    – Azz
    Oct 5, 2015 at 22:42
  • hi @Azz , I've update the post with newest firmware, please check it out Oct 7, 2015 at 4:40
  • Thanks! Mine isn't a ducky though unfortunately :(
    – Azz
    Oct 8, 2015 at 22:40

It seems like a bug of OS X EI Capitan. I have updated OS X to 10.11.2 beta version and the problem has been solved! Maybe you can try update your system. Please Google OSXElCapitanPublicBetaAccessUtility.dmg, join Apple beta plan and download that dmg file, then install that, and update your system in app store. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .