8

I use Apple Mail using two e-mail accounts (both IMAP but I don't think it really matters). Before El Capitan when composing an e-mail, one could choose the account the e-mail should be send from using a drop-down in the compose-window. However with the El Capitan update this dropdown is gone and there seems no way to select the account the e-mail should be send from after composing the e-mail.

The Mail settings do have an option to select the sending account. Here I can set it to one account or use the open mailbox as indication for which account to send mail from.

Is there any way to switch the sending account after composing an e-mail in El Capitan?

5

Select your preferred email address in Preferences > Composing > Send new messages from:

If for some reason that doesn't work, try rebooting.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    After noticing my second account was not in this list, rebooting it indeed fixed this for me. – thoutbeckers Jan 7 '16 at 12:54
  • 1
    For me Cmd-Q (entirely closing app) was enough. – SuitUp Jun 12 '16 at 21:56
3

I just added a new account and I needed to restart the Mail.app to have the From field show up in the New Message window:

enter image description here

1

I hit the same problem. My mail (under Yosemite) was configured with one IMAP a/c and one Exchange a/c enabled before the upgrade to El Capitan. Since then the From dropdown disappeared (and no - rebooting did not fix it). I added a second IMAP a/c, then the From dropdown would come back but only offer the either of the two IMAP a/cs. In the end I deleted the exchange a/c (and extra IMAP) and re-added the exch a/c. Presto! Back to 1xIMAP and 1xExchange a/c with from dropdown. So the good news is that mail v9 is fine. But the El Capitan upgrade process must have messed up migrating some exchange parameter/s.

You must log in to answer this question.

protected by Community Oct 12 '15 at 16:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .