36

I started to download the El Capitan upgrade, but then I shut down my computer. The day after I wanted to continue the download but in App Store it shows "Waiting..." and doesn't do anything. Also when I go to the updates section, it shows the button "Download" but it's inactive. Maybe someone can help me? I tried to find the download file in some directory to delete it and start over but I couldn't find it.

  • We encourage jeopardy questions where you ask a question and then answer it. Would you mind putting your answer in the answer and make the question clearer? If you had enough reputation to chat, we might be able to sort out the original closure, but it's best to collect all the possible answers to one symptom on one thread. that's why questions get closed as duplicate. – bmike Oct 1 '15 at 20:02
  • Why not just submit an answer to the other question? – bassplayer7 Oct 1 '15 at 20:05
  • @bassplayer7 This question is asking for a different error situation that shows Waiting... message. I think this is a valid reason to post a new question. – Eonil Oct 2 '15 at 1:42
  • Restarting AppStore a couple of times did the job. – Amro Shafie Oct 2 '15 at 12:19
  • 1
    The only thing that worked for me was running "Install OS X El Capitan" from the /Applications folder -- that was apparently left there as a result of one of my many Download attempts from the App Store. – l3x Oct 5 '15 at 16:38
50

In App Store, selecting Store > Check for Unfinished Downloads did work for me.

  • 1
    this is the right answer. Worked perfectly. – gbrandt Oct 9 '15 at 18:43
  • 1
    Didn't work for me, clearing the downloads folder did. – Michael J. Calkins Dec 24 '15 at 16:21
32

I've found the solution:

  1. Close the "App Store" App
  2. Open "Terminal"
  3. Enter defaults write com.apple.appstore ShowDebugMenu -bool true
  4. Open the "App Store" app
  5. Now you have in the menu-item "Debug" - open it - and open "Show Download Folder"
  6. Delete all files and folders in the folder "com.apple.appstore"
  7. Close the "App Store" app
  8. Restart the Mac
  9. Clean the trash bin
  10. Open the "App Store" app an repeat the download.

Now the download should work!

If you want to hide the debug-menu again just enter in Terminal:
defaults write com.apple.appstore ShowDebugMenu -bool false

  • 1
    +1 This solved my case. My Mac was stuck at Waiting stage for 24 hrs, and now it's running after I did this. – Eonil Oct 2 '15 at 1:43
  • I have the same problem. Where can I find the "TERMINAL", to be able to proceed??? – user149920 Oct 2 '15 at 16:56
  • 1
    Open your "Applications" folder, then open the "Utilities" folder. Open the "Terminal" application. – Yup Oct 2 '15 at 18:09
  • 1
    No Debug option available. – Green Mar 25 '16 at 7:58
  • A shorter version of this: 'Show download folder', close the app store app, delete the 'com.apple.appstore' folder, empty the trash, start the app store app again. No restart required. – Glenn 'devalias' Jul 6 '16 at 1:02

You must log in to answer this question.

protected by Community Oct 2 '15 at 19:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .