14

When I check and uncheck this System Preference "Automatically adjust brightness", my display gets slightly washed out instead of brighter or darker. It seems to be adjusting the gamma and the grays instead of the backlight brightness.

What's going on here and is it possible to restore the behavior of Yosemite and earlier with this option?

enter image description here

A sample of the gamma difference with setting enabled/disabled.

enter image description here

  • Supplemental: there seems to be some discussion of this on various google results related to "Ambient Light Compensation." (e.g. infinitediaries.net/…) – y3sh Oct 1 '15 at 15:54
13

It is a new feature called ‘Ambient light compensation’. Before the Beta 7 or so it was a separate option in that menu on your screenshots, but in newer betas and in the finale release Apple merged it with the ‘Automatically adjust brightness’ checkbox, so yes, it is now adjusting not only backlight brightness, but gamma as well.

The only solution I found so far is to turn off that checkbox and adjust backlight brightness manually, which isn't a solution really. Hope Apple will bring back a separate checkbox for ambient light compensation.

2

The solution, posted as a comment by user Nicnl, is as follows:

  1. Disable SIP:

    • Reboot into Recovery Mode (hold down ⌘R on startup).
    • Open Terminal and enter the following command
      csrutil disable
    • Reboot back into macOS.
  2. Open Terminal and type in the following:

    cd /System/Library/PrivateFrameworks/AmbientDisplay.framework/Versions/A/XPCServices/com.apple.AmbientDisplayAgent.xpc/Contents/MacOS/
    mv com.apple.AmbientDisplayAgent _com.apple.AmbientDisplayAgent

    The first command just changes the directory you are in, while the second one renames the file to something macOS can’t find.

  3. Enable SIP

    • Reboot into Recovery Mode (hold down ⌘R on startup).
    • Open Terminal and enter the following command
      csrutil enable
    • Reboot back into macOS.

Taken from here.

0

Have you explored the ambient light sensor in the display next to the iSight camera? You can shade it, shine a light in it and clean the surface of the glass.

If it's not an environmental change, you might want to disable that option and reach out to Apple Support to see if it's a bug in this build or if you coincidentally have a hardware failure at the same time as you did the software upgrade. It's clearly not likely, but it's possible.

  • The hardware sensor appears to be functioning perfectly after hiding/exposing it to light. – y3sh Oct 1 '15 at 15:55
  • @y3sh Bummer for you. I should have mentioned testing the backlit keyboard sensor and the display sensor (one senses the KB area, the other the top of the screen). If either is stuck, rebooting to reset the NVRAM might not be a bad idea. Worst case, before taking it in for service - reset the SMC just in case it's involved. It might be part of the measurement chain. – bmike Oct 1 '15 at 15:58
  • Thanks for the feedback, but the contributions of the answer mostly belong in a comment. I do believe this is related to configuration in El Capitan, which going to an Apple store and resetting NVRAM do not solve. – y3sh Oct 1 '15 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .