1

I am using latest version of OS X, whenever I want to download an .xls file from email attachment, it opens, by default, with Numbers and the file is not downloaded on my machine. How can I change this default behaviour?

3
  1. Right click on an Excel file.
  2. Click: "Get Info"
  3. Set the "Open with:" selector dialogue to whichever app you choose.
  4. In the "Open with:" section, there is "Change All..." button to change all files with the same extension.
1

When left-clicking it downloads automatically to your default (Downloads) folder, and is directly opened in the default Application. This is standard OS X behaviour. You can change the default App to open the .xls file as @IronCraftman describes in his answer. To only download the file and not open it (hover over the attachment icon) and right click and select "Download Linked File (As)" It wil download to the default (Downloads) folder. But won't open the associated App for the filetype. This works for Gmail, but probably for all webbased email.

  • edited: (now posted as alternative answer): Don't know if it works for .xls files as well, but you could try this: Go to: Safari > Preferences > General > Untick "Open "safe" files after downloading". – Robert Oct 1 '15 at 13:52
1

Don't know if it works for .xls files as well, but you could try this: Go to: Safari > Preferences > General > Untick "Open "safe" files after downloading".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .