2

A spacing next to the last icon at the right of the menu bar appeared after upgrading to Bartender 2 (see the screenshot below). It was not there before. How can I remove it?

a spacing next to the last icon at the right of the menu bar

I already tried:

  1. restarting Bartender 2 and my Macbook as advised on the support page
  2. reinstalling Bartender 2 (curious: after the uninstall it still displayed the spacing!)
  3. command-dragging the icon to the right (when letting go it reverts to it's original position)
  4. checking the .plist of Bartender 1/2 if something is wrong or different (couldn't tell)
  5. contacted Bartender support (no answer yet)
  6. upgrading from OS X Yosemite to OS X El Capitan (no change)
  • If the space is still there when Bartender is not installed then why do think this has to do with Bartender? maybe the space was already there and you just didn't notice it. – user3439894 Oct 1 '15 at 12:37
  • As you can read in the first paragraph: "It was not there before." Meaning directly before I upgraded to Bartender 2. Directly after it, it appeared. – Robert Oct 1 '15 at 13:00
  • Then since this is apparently a know issue with upgrading Bartender I'd suggest you contact Bartender Support – user3439894 Oct 1 '15 at 13:06
  • @user3439894 Thanks for reacting so quickly. But the support page seems to address this question, but the resolution there doesn't work for me. The support question is also about upgrading from Bartender 1 to 2 and not a clean install. (Which I subsequently did. I'll edit my post to reflect the order of actions.) I already contacted Bartender Support, but they aren't answering (yet). – Robert Oct 1 '15 at 13:12
  • @user3439894 if you would know about a different cause then Bartender 2 it would also be appreciated of course! – Robert Oct 1 '15 at 13:16
1

Bartender 2 2.0.1 fixes this, adding a preference in Preferences → Appearance:

Right most menu bar gap
Bartender 2 added a gap to the right of the menu bar when Notification Center was hidden, this is to maintain the default gap at the screen edge, a lot of users liked not having this gap, so this is now a preference under Appearance.

  • The developer of Bartender 2, responded the same to me with the solution: "This is an issue we have come across in the new release and theres a fix for it in a test build update that came out yesterday. Please check for updates (you may need to adjust your setting for accepting test builds). – Robert Oct 2 '15 at 12:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .