2

I was trying to install El Capitan. I went to erase Macintosh HD in recovery> disk utility as I wanted to do a clean install. It then deleted the Macintosh partition then gave me an error code saying it couldn't delete the disk image or something like that.

After that I go to partion my fusion drive and the partition button does nothing. I am now left with just the 'Fusion Drive', nothing else in terms of partitions. I tried to check the disk but that button didn't work either. After some research I think disk utility must have deleted the partition table?

Basically I need to create a new partition in my Fusion Drive hard drive. However disk utility is not letting me. I have gone into the properties of the fusion drive and it says 'Writeable: No'.

I think my only option is to create a partition using the terminal in recovery but I don't know how to do that.

Any help would be greatly appreciated.

  • You should've just "Erased" the partition. If you go under the partition tab when clicked on the Fusion drive, can you add a partition. – At0mic Oct 1 '15 at 1:49
  • @EdNorth Please add screenshots/pictures of the outputs of diskutil list, diskutil cs list and gpt -r show /dev/disk0 entered in Terminal – klanomath Oct 1 '15 at 5:29
1

Boot to Recovery HD (or Internet Recovery) and then use Disk Utility to format the drive(s) as part of this documented process to erase and install the OS.

Booting from recovery is what makes the partition map writeable. You were very close to the solution. If erasing doesn't work, you may have to repartition the volume per https://support.apple.com/kb/PH22240

As a last resort, boot to single user mode and/or Recovery and start terminal and get a screen capture/picture/verbatim listing of the output of:

diskutil list
  • 1
    That is what I tried doing. I have researched some more and people are having the same issue with the fusion drive. I've read I need to run this command along with a few others: diskutil cs delete UUID – Ed North Oct 1 '15 at 2:03
  • 1
    If you boot to Recovery and enter Terminal - what does diskutil list show? You might need to use a camera to screen shot it... little details matter and typing all the info would be onerous. This is the sort of thing AppleCare online chat might be excellent at resolving quicker than back and forth here, but I'm game if you don't mind some delay... – bmike Oct 1 '15 at 2:51
  • Pay attention to disk0, disk1, disk2 and any unmounted / offline logical volumes. – bmike Oct 1 '15 at 3:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .