I downloaded, and then started installing OS X El Capitan on my MacBook Pro. But I think it just stacked i think. So I turn off mac, and then turn on again. Every time when I try to login on my account I have a crash as following:

enter image description here

Is there a way to reset this and download again?

I am really appreciate for any help. I do not know what to do.

7 Answers 7


I did it with simply press Cmd + R, and then press off. Cmd + R I kept pressed until Apple logo appeared, then I get into Install OS X mode. There you should once again connect to the internet, choose language,and waiting for new install.

  • 1
    Perfect. Please come back and tick this as answered if a simple reinstall was all that was needed. It will help lots of people to know what worked for you :-) (and if it doesn't work, perhaps we can edit our answers if you still want help getting the install done)
    – bmike
    Commented Oct 1, 2015 at 17:49
  • Unplugging everything during the install was the key for me. Thank you, @bmike.
    – MXMLLN
    Commented Nov 3, 2015 at 15:26

Yes - this is generally an easy recovery - the next step is to get a backup (which will be a pain if you don't have one) and then perform an erase install.

That part should go easily. If that fails, you likely have a hardware error that would need to be addressed. Also, if you haven't tried disconnecting everything from the MacBook that you can except power. No USB, no ethernet, no thunderbolt, no SD cards, etc...


Had the same problem with my MacBook Air 11" 2013 model. None of the provided solutions worked for me. I also tried to reinstall El Capitan by booting into recovery mode. I reinstalled it two times but the error kept showing up.

So here's how I solved the problem:

  1. Shut down your mac.
  2. Boot into safe mode (Hold shift while booting up). Hint: During the screen with the Apple logo and the progress bar, nothing will look different, but at the login window, there should be "SAFE BOOT" on the top right corner of the screen to confirm that you are in safe mode
  3. Log in again. This time it should work, if it doesn't go to step 1 again.

  4. Finish up the installation process.

  5. Backed my data up
  6. Fresh reinstall

I got the same error and contacted apple support. They walked me through the steps to reinstall OS X which will take several hours. Fortunately I have a time machine back-up that I can use once complete

  • Yay for backups!
    – bmike
    Commented Oct 1, 2015 at 3:11

I had this error as well. But I found restoring from Time Machine troublesome, as the Setup and Migration Assistants both refused to restore data from the TM backup, reporting there wasn't enough space in an 890GB OS X partition to store 400GB of data.

When I next attempt to install El Capitan, I'm going to create a bootable clone of the boot drive using Carbon Copy Cloner, so I can restore from that if needed.

But before that, I'm going to run Apple Hardware Diagnostics to check for hardware issues.

  • I just managed to install El Capitan without a hitch on the second attempt. I did run Apple Hardware Dianostics, but no problems were detected. This time round I unplugged every external device - USB hub, monitor, Time Machine etc. Don't know if that made the difference though. Commented Oct 2, 2015 at 13:03

Fixed! Had the same problem with late 2011 MBP--reinstalled El OS three times, still crashed on first login attempt. The problem I think resides with the new System Integrity Protection (SIP). You can't repair permissions anymore, and any offending files in the system folder will cause problems. I pulled the drive, attached to another Mac, and using EasyFind, searched for Extensions folders, sorted on date, and removed old plist files (most were from the same 2015 date and from Apple). For good measure, I also searched for StartupItem folders and removed anything that looked fishy (sorry, I tried so many different things that failed before this that I can't remember exactly).


I couldn't find the sxuptp.kexp file, but I compared the list of *.kexp files in the crash log file under folder /Library/Logs/DiagnosticReports and all the kexp files in /System/Library/Extensions/ . The last kexp file in the crash log is com.apple.iokit.IOACPIFamily or correspondingly IOACPIFamily.kexp. I looked into the folder /System/Library/Extensions/ and find that the next file after IOACPIFamily.kexp is LivescribeSmartpen.kext. If you heard of the smartpen, you will know. I moved it to the desktop (or any other place). This fixed the problem. The system boots up and jumps out of the crash loop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .