I am trying to make a symbolic link inside the /System folder and even if I run the command as su I get the following error message.

macbook-pro:~ root# cd /System/Library/Perl/Extras/5.18 
macbook-pro:5.12 root# ln -s /Applications/Xcode.app/Contents/Developer/Library/Perl/5.18/darwin-thread-multi-2level/SVN/ SVN 
ln: SVN: Operation not permitted
macbook-pro:5.12 root# ls -ld /System
drwxr-xr-x@  4 root  wheel restricted 136 Sep 22 10:37 System

How can I get this working?

  • You need to disable SIP – At0mic Sep 30 '15 at 21:58
  • I tried doing that by logging into Recovery mode and using terminal to run csrutil disable and I still have the same issue. – Vish Sep 30 '15 at 21:59
  • hmmm... I don't know what else to do. Where are you running the command from. What user account? – At0mic Sep 30 '15 at 23:10
  • There's a bunch of stuff in the Apple Forum Post about this: forums.developer.apple.com/thread/3981 also I think there's an option to disable it from the Firmware Password tool in Recovery. – Andrew Oct 1 '15 at 0:10

I am guessing you are doing this to get git-svn to work. I've tested this on git 2.6.2. If so, link to non restricted directory:

sudo ln -s /Applications/Xcode.app/Contents/Developer/Library/Perl/5.18/darwin-thread-multi-2level/SVN/ /Library/Perl/5.18/SVN
sudo mkdir /Library/Perl/5.18/auto
sudo ln -s /Applications/Xcode.app/Contents/Developer/Library/Perl/5.18/darwin-thread-multi-2level/auto/SVN/ /Library/Perl/5.18/auto/SVN
  • This worked for me to fix the error "Can't locate SVN/Core.pm" in SourceTree. – newenglander Feb 11 '16 at 11:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.