After updating to latest developer release for OS X El Capitan, I can't login in Mac App Store or OS X iCloud settings. If I try incorrect password, a message is shown that the password is not correct. When I try my real password, the loading icon just spins forever.

I already tried to remove Network settings plist file and some other things found on forums. System log file shows a lot of these few messages, especially when doing something with iCloud login.

SOSAccountThisDeviceCanSyncWithCircle sync with device failure: Error Domain=com.apple.security.sos.error Code=1035 "Account identity not set"  

and

01/10/15 00:11:52,599 storeaccountd[591]: XPC error for connection com.apple.backupd.sandbox.xpc: Connection invalid  

and

01/10/15 00:11:52,931 sandboxd[226]: ([591]) storeaccountd(591) deny mach-lookup com.apple.backupd.sandbox.xpc

Unfortunately I do not have backup of my previous installation. Also I can't update to latest El Capitan version, because App Store login is not working.

  • To be more precise, I just want App Store to be working again and probably install the latest version of El Capitan. – Vilis Sep 30 '15 at 21:30
  • Also this issue has been going on for a few days, so it shouldn't be related to busy servers. – Vilis Sep 30 '15 at 21:31
  • System Version: OS X 10.11.1 (15B17c) – Vilis Sep 30 '15 at 21:31
  • I had the same problem and my solution is I created another admin account: System Preferences > Users & Groups > Click the Lock Icon and I add another account with admin rights and separate password then logout the current user then Login with the new account I created and then reset my old user name to use separate password not the iCloud password. – kedomonzter Oct 2 '15 at 14:24
  • 1
    I am unable to add a new answer to this question, but having had the same issue, it turned out the push notification service wasn't running which resulted in the logins not working for me. @Tetsujin's answer together with (re?)starting the service like I commented under his answer might solve it for you too. – A.S. Dec 7 '15 at 2:20

NOTE: This solution is primarily meant for users of physical Apple devices, such as MacBooks, iMacs, Mac Pros, etc. While I will mention a link to a solution for virtual machine users as well, that is not the primary objective of this post. As such, that will not be posted here, for succinctness.

Also, while NVRAM (non-volatile RAM) does save certain settings and parameters for long-term, iCloud settings don't appear to be among the settings saved in NVRAM.

The solution will sound simple - but it's not. The full-out solution is a three-step process, which will force OS X to do the following:

  • Wipe the existing, problematic settings file(s), and force OS X to reproduce valid ones in there place.
  • (Re)Start the iCloud service and/or its required related Daemons.
  • Validate/rewrite (hardware) machine details if required.

We’ll start by deleting the following file (admin permission required): /Library/Preferences/com.apple.apsd.plist

We’ll then ensure that the proper LaunchDaemons are running - in this case, Push Notifications. iCloud needs this running to operate. Enter the following into Terminal:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.apsd.plist

Finally, please check to make sure that your OS X device has a (valid) Serial Number. Whether it’s real or virtual machine, the Serial must be less than 12 chars - otherwise, iCloud -based services like FaceTime and iMessage won’t be able to sign in (or will ‘hang-up’ at sign in attempt). Check this in your Mac’s ‘About’ section. If you have either a NULL or invalid Serial Number, please do one of the following:

  • Either use your Apple Care/Warranty to contact Apple. Have them set your hardware Serial Number, seeing that they were supposed to do this when they were done servicing your machine.

OR

  • Use the following application to change this (if you can't go to Apple for any reason, and aren't worried about voiding the device's warranty). Please do NOT use this tool if you have Apple Care or would like to preserve your Apple Warranty:

Blank Board Serializer - Downloadable from here:

http://rogersm.net/icloud-problems-mountain-lion-serial-number


Now, for those of you using a virtual machine, please go here to complete the third step (Serial Number reset). You'll need to generate a valid, new Serial Number that is NOT currently in-use:

http://www.insanelymac.com/forum/topic/292170-how-to-spoof-real-mac-in-vmware/


That should fix any issues with iCloud sign in and use of its related services for El Capitan. Works for most physical Mac OS X devices and VMware Workstation installations.

It would appear from much research that iCloud, iMessage & FaceTime are inextricably linked & that to fix one, you need to 'fix' them all.

What finally got me there was the Safe Mode boot followed by deleting /Library/Preferences/com.apple.apsd.plist
Nothing else worked.

Far too much to post here, but see my answer to Messages won't let me sign in to iMessage & also the excellent post by Linc Davis at https://discussions.apple.com/thread/7272123

  • 2
    While your answer doesn't contain the solution directly - I already deleted the plist file and it didn't help - it brought me on the right track. For some reason logging into iCloud requires the push notification service to be enabled. Either I had this disabled since quite a while and this requirement is new in El Capitan, or it got disabled by itself when updating, but ultimately running sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.apsd.plist was what solved the issue immediately. – A.S. Dec 7 '15 at 2:12

As everyone else has mentioned, it's a problem with the serial number. I also just encountered this, but on a virtual machine. By default, Fusion gives it some extremely long serial number, which the App Store doesn't like. To fix, edit the .vmx file and add the following line:

SMBIOS.use12CharSerialNumber = "TRUE"

Hope this helps!

I was suffering the same problem and someone on another site said that they solved their problem by quitting their VPN app, which I myself had running. Once I did that everything worked fine and I was able to sign into iCloud.

  • 1
    Sadly this is not the case because I am not using VPN or anything related to that. Also I have tried safe mode, resetting network, etc. – Vilis Oct 1 '15 at 10:35

I had the same problem yesterday and today. Turns out my macbook was lacking a serial number (no idea how it got deleted). I used the software Blank Board Serializer to write it anew and was able to log in.

So check your serial number.

I had the same problem and that I was able to fix it. Select [Apple] and "This Mac". If there is no serial number you need to restore it. Find the serial number on the chassis of your Mac. Find tool "Blank Board Serializer" somewhere in the Internet Create a bootable disk or USB stick and use it. After entering the serial number, return is possibility of logging on to the App Store, iTunes Store, iCloud and iMessages

I had the same problem and after searching the web for a while I found that I just had to logout and log back in from the Store menu.

I found the solution

I hope work on your mac

https://support.apple.com/en-us/ht204063

Bye

  • 1
    Tried NVRAM, didn't help. – Vilis Oct 2 '15 at 8:26
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Oct 2 '15 at 9:58

protected by Community Oct 2 '15 at 9:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.