3

The short version:

I was running Boot Camp on my Retina MacBook Pro, but I decided just recently to ditch it because I never use it and I'd like to reclaim the space. The official method of removing it with Boot Camp Assistant failed so I went the harder route involving booting into Internet Recovery mode and deleting the partitions manually, which worked and gave me the space back - except when I rebooted I got a Windows screen telling me booting failed, and when I hold down OPTION on a boot I still see "Windows" as an option.

If I pick OS X when I hold down OPTION it boots like I want it to but on a restart it still gave me the Windows error screen. Booting into Internet Recovery again and setting "Macintosh HD" as the Startup Disk seems to have fixed it and now on subsequent reboots I'm in OS X like I want again, but I can still see "Windows" as an option as I hold down OPTION on reboot.

Is there any way to get rid of this "ghost" of Windows/Boot Camp on my system and if there's not, is this something I should be concerned with?

The long version

So here's the sequence of events:

  • Got my rMBP in 10/2014
  • A few months later I added Boot Camp, initially with Windows 8.1 and later upgraded to Windows 10
  • The other day I decided to ditch Boot Camp as it's taking up space and I never use it.
  • Did a few different backups
  • Uninstalling Boot Camp via the Boot Camp Assistant didn't work, which is apparently really common
  • Read online that the next best thing is deleting the Boot Camp partitions directly and/or modifying them to appease Boot Camp Assistant
  • Tried removing the Boot Camp partition in Disk Utility. It wouldn't let me. (By the way, Disk Utility is really crappy and unusable in El Capitan - they've removed the old standard partitioning method and replaced them with a PIE CHART that doesn't work half the time)
  • Did lots of reading, a fair amount of panicking, and booted into Internet Recovery mode
  • Using the Disk Utility in Internet Recovery Mode (which is the old one from Mavericks/Yosemite, yay) I was able to do a series of maneuvers that, long story short, allowed me to delete the Boot Camp partition - along with a couple of others that, I'm guessing, are artifacts of Windows/Boot Camp - and got back to one big huge partition. I happily restarted...
  • ...and was presented with a clearly-from-Microsoft screen (fonts, colors, etc.) saying Windows couldn't load. At this point I've got the "No! We killed you!" scene from Robocop going through my head
  • Reboot, hold down OPTION, and I see Macintosh HD and Windows. I pick Macintosh HD
  • OS X boots up, I have all my space back, life is wonderful
  • Reboot the Mac to see what happens and I'm back in Windows error land
  • Back in OS X (after rebooting and holding down OPTION again) I go to Startup Disk in System Preferences and try to set Macintosh HD as the start disk but it won't let me do anything because there's only one hard drive now and as far as it can tell it's already the startup disk
  • I booted the Mac into Internet Recovery mode and set the Startup Disk to Macintosh HD (since, I'm guessing, when you're in Internet Recovery mode you're booting off of the temporary-from-the-Internet disk) and restarted.
  • Mac restarts in OS X like I want it to
  • Reboot again, Mac still restarts in OS X like I want it to. Did this a few times to be sure.
  • Reboot again, hold down OPTION, I can still see Windows as an option but I don't know where it's coming from

So basically things are where I want them to - except there's this "ghost" of my Boot Camp install lingering. Is there any way to get rid of it? And failing that, can I just ignore it safely?

  • If you can, post the output from the following Terminal application commands: diskutil list, diskutil cs list, sudo gpt -r show /dev/disk0 and sudo fdisk /dev/disk0. These commands will not change your computer. Some may ask for your login password. This is normal. – David Anderson Sep 30 '15 at 21:36
  • @DavidAnderson: pastebin.com/JB1vtLnt Is the "EFI" line related to the culprit at all? – Tom Kidd Oct 1 '15 at 1:27
4

You did a good job removing the Widows related partitions. I assume your Windows 10 was an EFI/GPT install, therefore you probably still have code left in the EFI partition (disk0s1).

To view the contents of this EFI partition you have to mount it. You can do so with the command shown below.

sudo diskutil mount /dev/disk0s1

Below is a what I have in my EFI partition. I do not have any EFI dependent operating systems installed. If you have any folders that are Microsoft related, you can delete them. For example, the folder EFI/Microsoft.

enter image description here

You can also look for the folder EFI/BOOT. The apple firmware will recognize the file bootx64.efi in this folder as the default name for removable operating systems. You can delete this folder.

When finished, unmount the EFI partition with the following command.

diskutil unmount /dev/disk0s1
  • 1
    Out of curiosity, in Disk Utility in El Capitan, my hard drive (APPLE SSD SM1024F) shows 998.87 GB used for Macintosh HD and 1.12 GB "free space" and the pie chart interface gives no way of using that space (and Disk Utility in Internet Recovery mode doesn't show it at all). I don't care about that last 1.12GB of free space (especially if trying to reclaim it would be difficult) but I'm wondering if that's a side effect of the Boot Camp process or what. My work MBP (500GB SSD, never had Boot Camp) shows 100% of the disk used. Is that 1.12GB the EFI and Recovery Boot partitions? Thanks again. – Tom Kidd Oct 1 '15 at 19:55
  • just in case people run into an issue mounting, type in sudo before the command – David Nguyen May 16 at 19:52
0

This worked a treat but for slow learners like myself it might be worth mentioning that after you mount EFI using the command window you then go to finder to look whats inside it and after deleting everything windows from EFI using finder you then return to the command line to unmount the EFI. But it worked brilliantly. Thanks

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .