1

I just set up homebrew on my new macbook and used the brew and brew cask commands to install some applications. I can now open the applications from the launchpad but not from the terminal.

I know it's not working because the applications have not been saved to one of the directories in my $PATH variable, but none of the installation guides I have read for homebrew mention how you can set it up to put links to the binaries there. Some tutorials mention you should change the order of directories in your /etc/paths file, but I already did that and my problem persists.

Can anyone help me out? :)

1

Add the following to your ~/.bash_profile:

export PATH=/usr/local/bin:$PATH

This prepends /usr/local/bin to your existing $PATH.

  • ... settings apply on newly loaded terminal windows – CousinCocaine Sep 30 '15 at 16:24
  • This did not solve my problem, unfortunately (I quit and restarted the terminal of course). Installing an app with brew cask puts the .app file into /opt/homebrew-cask/Caskroom/, and a symlink is created at ~/Applications. usr/local/bin doesn't contain any of the installed apps, though. – zinfandel Sep 30 '15 at 16:44
  • Turns out this only applies to apps installed via brew cask. brew-installed apps are fine. – zinfandel Sep 30 '15 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .