I'm having the strangest issue since updating to OS X El Capitan. My "Open File" dialogs show the sidebar but all my main (and useful) locations are missing. Take a look at this screenshot. This screenshot shows Keychain Access but this happens in Safari when I'm trying to attach a file to Gmail for example, or uploading an image to Facebook.

What I would like is for the sidebar to show my home directories, such as Desktop, Documents, Downloads, etc.


enter image description here

  • 4
    Only in the file-picker dialogs @Tetsujin, Finder itself shows the sidebar content as it should. – Arno Sep 30 '15 at 14:26
  • 4
    I have this too - and it also does it in Chrome. Reboot temporarily fixes it. Seems like an El Cap bug. – niico Oct 8 '15 at 13:58
  • 1
    Same problem, you can go to Finder>Preferences>Sidebar and check them all, they will remain there in Finder... but NOT in any programs. For example, I open Photoshop CC 2015 and if you drag the folders you want into the Favorites area, they will NOT be there when you reopen the program. Same for ALL programs across the board. This is very frustrating. – user151936 Oct 12 '15 at 12:44
  • 2
    This sucks.. same problem. Still here in 10.11.3. – billynoah Feb 24 '16 at 3:04
  • 4
    I added a working, simple solution at the bottom of this thread. Have a look at that. Unfortunately, due to the rank-based-on-votes system I guess many people won't see it until it gets more votes and "floats up". – d-b Nov 17 '17 at 6:40
  1. Go to your user library in Finder. Hold down while opening the Go menu and click Library.
  2. Navigate to the Preferences folder.
  3. Remove any files that are or contain com.apple.finder.plist. (The removal of those files will very likely reset your Favourites list in Finder.)
  4. Restart or log out and log back in again then empty the trash and try again.

    Restarting might not be necessary. As madpoet says:

    You can also relaunch Finder if you don't want to reboot or log out. Right click on Finder icon while you're pressing and you'll see the Relaunch option there.

    Relaunch Finder.

Alternatively, you can use this Bash oneliner by Christophe Marois:

cd ~/Library/Preferences && sudo find com.apple.finder.plist* -exec rm {} \; && killall Finder
  • 3
    This finally did it! I had to remake my favorites though, – benstpierre Nov 12 '15 at 21:48
  • 46
    That did it. Bash one-liner: cd ~/Library/Preferences && sudo find com.apple.finder.plist* -exec rm {} \; && killall Finder – Christophe Marois Dec 6 '15 at 20:24
  • 13
    @ChristopheMarois That managed to just remove Favourites completely from Finder with no fix for the file open/save dialog. – Constant Meiring Dec 9 '15 at 11:13
  • 8
    Fixed for me but needed to log out and not just kill Finder! @ConstantMeiring the favourites disappered befor the logout, but then they came back as they were before! – Pincopallino Jan 5 '16 at 22:04
  • 6
    Keep your old com.apple.finder.plist around safe somewhere just in case this wipes out something you care about (e.g., all your Desktop settings). After doing this, you can restore the old plist and the fix seems to stick. – orome May 15 '16 at 20:39

I had the same issue and fixed it in the following way:

  1. While in a "Open File" or "Save As" dialog box (that doesn't show Favorites), drag any folder to the sidebar. This will create a "Favorites" category in the sidebar that only shows that folder.

  2. Reboot.

After rebooting, all of the dialog box sidebars should show Favorites as it appears in Finder, synchronized.

  • 12
    This isn't a fix - it's a temporary workaround - it goes away again (for some reason). This is a bug in El Cap. – niico Oct 8 '15 at 13:58
  • Is the top entry in your Favorites “iCloud Drive?” If so, you might try moving another folder to the top position and re-booting. A non-default folder, for instance. I suspect that it’s something to do with iCloud Drive with respect to Favorites. I noticed that on one of my El Cap MacBooks, the fix stayed, but on another MacBook, it didn’t. The only difference was that iCloud Drive was the top entry in the one that kept disappearing. Now both are ok. – highcool Oct 9 '15 at 2:46
  • 1
    My top item is 'Devices' - iCloud Drive isn't listed so your hypothesis appears wrong and I predict both your machines will fail again. – niico Oct 9 '15 at 13:54
  • This worked for me, at least for now - will see if the problem crops up again! – Greg Annandale Feb 2 '16 at 10:52
  • 1
    Thanks! This is the best fix, the other one involving deleting the files will make you reconfigure Finder again. – Reda Lazri Mar 25 '16 at 8:50

I had the same problem. I resolved it by going into the Finder and making a change to the Favorites area (eg dragged a folder in Favorites up one position). After closing the finder window and reopening to make sure the change stuck, I rebooted. File/Open then worked as normal.

  • This is a really frustrating issue. It's amazing how something so simple that causes so many headaches when it is not working properly. – RightHandedMonkey Nov 7 '15 at 13:07
  • 1
    that was great... I didn't even have to reboot, just restart Finder after moving one sidebar item one position up – davidhq Jan 31 '16 at 10:23
  • 1
    this killed my favorites from finder too, lol )) ok, fallback to cleaning preferences – zxcat Apr 3 '16 at 13:04
  • This one works for me, and even better is a) non-technical and b) doesn't nuke your favourites. I presume it works for everyone!? – Dave Stewart Apr 29 '19 at 18:36

The solutions above are both complicated and do not work. Kill sharedfilelistd and restart Finder. Problem solved (at least for a week or two according to my experience).

  1. Launch the Activity Monitor,
  2. Kill as many processes called sharedfilelistd as you can,
  3. Hold Option/Alt key and right click Finder icon in the dock,
  4. Relaunch Finder,
  5. Enjoy.
  • 5
    wow! The first thing that really works, besides restarting... – Peater de Xel Nov 26 '17 at 0:53
  • 3
    Great to hear, please upvote my comment to the original question so more people will see this solution (you might need to click Show more comments to see it). Thank you. – d-b Nov 26 '17 at 2:26
  • 3
    Thank you! This worked for me when other solutions (including the bash one-liner by Christophe Marois) did not! I'm running El Capitan 10.11.6 for reference. – Kobold Dec 25 '17 at 1:21
  • 3
    This should be the only answer. – Nimrod Feb 27 '18 at 5:48
  • 1
    Fixed the problem I had on Sierra – ocroquette Jul 7 '19 at 14:37

Go to Finder -> Preferences -> Sidebar, and put a check next to all your Favorites.

Finder - Preferences... Finder Preferences - Sidebar

Installing El Capitan might have reset a few of your original settings (it reset my desktop backgrounds). It comes with the territory when installing major updates, but this should fix it.

  • 5
    Negative. Doesn't fix it :( – Toby Oct 28 '15 at 18:07
  • 4
    This worked for me in finder, but not in file open panels. – vy32 Nov 25 '15 at 21:31
  • 9
    The problem doesn't lie with Finder, but in the file open/close dialogs. – Constant Meiring Dec 9 '15 at 11:14
  • Right, this wasn't about a Finder issue, but with a problem occurring only on open/save dialogs. Thanks for the effort though. – Demis May 31 '16 at 20:45
  • Fixed it for me just fine, the accepted answer removed everything for me ... so IMO this is the best answer – sMyles Oct 12 '16 at 16:43

Open a Finder window; you can drag folders onto the sidebar, and they’ll appear under a badly-named “Favorites” section.

Weird, but I think I like it. Keeps the plebeians out of trouble, makes it mo’ fancier for power users.

EDIT haha it doesn’t have any memory… stuff dropped into Favorites disappears. What is going on here… filed in Apple Radar #22916266

  • What is "Apple Radar"? – Noah Feb 23 '16 at 14:52
  • Apple’s bug tracker bugreport.apple.com – Eric_WVGG Feb 24 '16 at 18:24
  • 1
    Thanks, I thought so. I can't seem to find the bug with that ID. Can you tell my what the status is? – Noah Feb 24 '16 at 18:36

Today I received a reply to this very bug report I posted in nov, 2016. It's resolved in 10.13 GM, according to it.

Issue is resolved according to apple

  • Holy s$^t. Like more than a year after it was first reported, and many iterations of OS X later... Apple thinks the new major update might fix it. Let's see. – inspirednz Sep 27 '17 at 4:05
  • My mistake... may that "nearly TWO years after it was reported here..." – inspirednz Sep 27 '17 at 4:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .