10

I am successfully synchronizing my iPhone contacts with my GMail account.

When adding a new contact in my GMail account, the new contact takes a few hours to sync to the device. This is cumbersome, because often I add a contact on GMail and wish to call that contact from my iPhone.

Is there a way to force an iPhone contact sync update with my GMail account, so that new contacts will be immediately updated on the iPhone?

2

External account settings can be found under Settings-> Mail, Contacts, Calendars-> Fetch New Data.
Configure the frequency of synchronization on the bottom of the screen. It is possible to update in "real time" if "Push" is turned on, but this will have a negative impact on battery life.

  • I don't think "Push" applies to Google sync. It seems to be a global switch, but every sync provider (including Google) can be configured individually - and the only options for Google accounts are "Fetch" and "Manually". – Nickolay Nov 25 '15 at 10:08
  • Though I noticed that if you configure a Google Apps account as "Exchange", the changes are synced instantly. On the other hand, it's harder to configure and a quick search indicates that syncing via Exchange has other limitations. – Nickolay Nov 25 '15 at 10:12
  • My "fetch" is scheduled to "manual". Anyhow idea how to initiate a fetch? – Frank Schwieterman Jan 18 '17 at 7:26
  • I don't have enough reputation to answer, but for me, what solved the problem was getting rid of the labels associated with the contacts in Google Contacts (specifically the one associated with "Imported on...") – moomima Sep 4 '17 at 7:19
17

[update 2016-09-02] in iOS 9.3.5 you can simply pull down in the Contacts list to force a sync.

If this doesn't appear to work, make sure the problem is with syncing and not with the data iOS "sees" in the Google contacts by testing on a separate contact. For example, I had a problem (while on iOS 10.2) where the phone number wouldn't sync because it was in a wrong field of the Google contact.


In earlier iOS versions there used to be a sync button in the upper-left corner of Contacts app, now it seems to be gone (though some claim it can reappear under certain circumstances). There also used to be a way to force sync by pulling down in the Contacts app -> Groups view, but it doesn't work for me (and others) in iOS 9.1 either. This discussions.apple.com thread is useful to see the evolution of this feature.

Luckily, there's another thread with a collection of weird workarounds to force a sync without toggling contacts sync off/on or restarting the device. The following two ways worked for me to force syncing with Google contacts on iOS 9.1:

  • 4
    For the record, simply going to Settings -> iCloud worked for me on iOS 9.2. – mpontillo Jan 6 '16 at 22:44
  • 2
    IOS is updated. All you have to do is pull down the contacts list for a manual update. You'll see the spinning thing. To update calendar, go to the inbox in calendar and pull down. – byrdzeye Sep 2 '16 at 19:10

You must log in to answer this question.

protected by Community Mar 26 '16 at 13:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .