1

I'm relatively new to OS X and I'm loving it. I've got a MBPr (15″ Late 2013 2.6HGz Core i7 Yosemite 10.10.5 16 GB 1600MHz DDR4 GT 750M, 2GB) that has been serving me brilliantly except for a very odd problem with my graphics card that exhibits strange behaviour when I plug it in to my 4K monitor. The problem is basically that in certain display configurations, and under certain loads, kernel task CPU usage will skyrocket to 400%. The problem disappears when I unplug my display.

Here's what a typical occurrence of this problem will look like

Image of GPU problem

  1. Boot
  2. Activate load
  3. Kill load
  4. Unplug monitor

Load can be anything from yes > /dev/null & to playing netflix, but generally kernel task gets stuck on 400%, it stays there until i unplug the monitor making my computer unusable for intensive tasks.

Instead of asking someone on here to fix it, I'd like to get some tools that people use to diagnose this problem and try and fix it myself (unless someone on here knows the answer).

Here's what I've tried:

  1. Installed latest updates
  2. Cleared my SMC and NVRAM
  3. Fresh-installed from scratch
  4. Killed all startup agents and services
  5. Tried different scaling resolutions

Although performance is much better on a fresh install, I could still replicate the problem eventually.

Here are some results of tests that I've performed. May not be that helpful but I'll include anyway.

CPU only stress tests:

Scaled 4k on miniDP and internal with CPU stress test
Problem occurred
Native 4k on MiniDP and internal with CPU stress test
Problem doesn’t occur with this CPU stress test
Scaled 4K on HDMI and internal with CPU stress test
Problem doesn’t occur with this CPU stress test
Native 4K on HDMI and internal with CPU stress test
Problem doesn’t occur with this CPU stress test
Scaled 4K only on mini-DP with CPU stress test
Problem doesn’t occur with CPU stress test

When on 4K display switches to nvidia card then back to Intel card when unplugged When viewing native resolutions on both screens, simply editing a Google Drive spreadsheet can trigger kernel_task spike, problem goes away when unplug display and switch back to Intel Iris Pro.

When viewing native 4K on external monitor only, editing Google Drive spreadsheet seems to be ok.

Can be triggered when viewing “default” resolutions on both 4K and internal monitor and only using minor tasks  Scaling on MacBook Pro display, no scaling on 4K monitor, just browsing Safari, will get triggered, goes away when unplug monitor and plug back in.

Only seems to happen when CPU usage is elevated very quickly, seems to handle it by throttling the cpu if usage is increased slowly.  The whole time I’ve had this laptop I’ve experienced glitching artefacts while on the NVIDIA GPU.

POST REINSTALL

Plugged in 4K display, and enabled scaling to 3008 × 1692 Scaling on built-in retina: 1680 × 1050
Resolution: 1 sec

TEST 1: Procedure:

  1. Started YES stress test × 20
  2. Started maps 3d flyover of Sydney
  3. Killed YES stress test

Result: eventually stabilized  TEST 2: Procedure:

  • same as test 1

Result: eventually stabilized
 TEST 3: Procedure:

  1. Start iTunes playing something
  2. play around with a spreadsheet on numbers
  3. Open up Facebook, start scrolling

Result: eventually stabilized  Test 4:

  1. Play Netflix on Safari
  2. kill Safari

Result: eventually stabilized  TEST 5:

  1. Just Netflix on Safari 2. Scaled down to 1920 × 1080 netflix on full screen: 3. Scaled up to 2560 × 1440 while video is playing 4. Slowly scale up to 4K while video is playing 
 FRESH RESTORE OF FILES
    Fresh restore of files, open Netflix on scaled 4K: GPU problems
    A few seconds of watching Netflix on the 4K monitor at scaled resolution fresh after restore. Red continues for a few minutes until unplug monitor cable

Created new user on fresh reboot: could stablize kernel_task

kernel_task would spike in new user if logged in after old user, but not if new user is logged in on fresh boot. Possibly a config issue on old user.

I took my computer into the genius bar the other day and they cleaned out a bunch of dust, and haven't been able to reproduce this problem, which is pretty weird. It seems to be a problem that is activated by certain thermal conditions. Haven't seen anything weird in kernel logs, don't get kernel panics more than usual, nope, I've got a 750M.

  • Have you checked your console logs? Anything interesting at the instance when the spike starts/stops? – user149252 Sep 30 '15 at 2:26
  • Are these your graphics cards? _Intel HD Graphics, Built-In, 288 MB_ & _NVIDIA GeForce GT 330M, PCIe, 512 MB_ – tjt263 Oct 6 '15 at 8:02
  • Also, have you encountered any "Kernel Panics"? – tjt263 Oct 6 '15 at 13:25
1

To start Apple Diagnostics:

  1. Turn off your computer if it is on by choosing Shut Down from the '' menu.
  2. Press the power button to turn on your computer.
  3. Immediately press and hold the D key until Apple Diagnostics begins.

Straight from Apple Inc.'s official documentation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .