22

After upgrading to one of the beta El Capitan builds, I can no longer use the "start screensaver" hotcorner. Other hotcorners still work, so it's not an issue with an application grabbing mouse input and blocking hotcorners from being detected (for example, I can configure the display to turn off and that works fine) and the screensaver itself works, too.

This is on El Capitan public build 15B17c, and has persisted through the few beta builds. Moving the mouse to the corner assigned to "start screensaver" simply has no effect. I've tried disabling and enabling the option, rebooting, checking disk permissions, etc. to no avail. Any other suggestions?

  • 1
    Just found the same, very annoying :( I usually used that simple gesture to quickly block my Mac (in pair with "Block my Mac after 5 seconds of screensaver" setting) -- was very, very handy. – Vladimir Tolstikov Oct 4 '15 at 8:41
  • 1
    This happened to me when upgrading from El Capitan to macOS Sierra – Daniel V Dec 1 '16 at 0:01
27

What worked for me:

1) Change the hot corner action to something different. It should work.

2) Restart your Mac

3) Change the hot corner back to the original action.

I just checked that the action keeps working after a restart.

I'm on MBP 15'' Retina Mid-2014 with El Capitan.

  • 1
    This worked for me for OS X El Capitan 10.11.1 (15B42). – Keith B Oct 22 '15 at 1:10
  • This is the only solution that worked. Obviously a bug of some sort, thank you very much! – Mahmoud Al-Qudsi Oct 22 '15 at 21:53
  • This also worked for me, but one caveat—in step #1 only one or two of the hot corner actions worked for me. I set all of my hot corners to "Show Notification Center" (one of the few that worked) then restarted my Mac. After restart, I was able to switch back to the "real" hot corner actions as described in step #3. – Matt Korostoff Dec 6 '16 at 17:49
  • 2
    This works for Sierra as well. – Anriëtte Myburgh Jan 12 '17 at 8:43
2

Go to System Preferences, change your hot corners to other random ones, restart your Mac, and then go back to settings and change hot corners back to starting screensaver.

  • 3
    That unfortunately does not work for me. The replacement actions work just fine, but reverting to the "start screensaver" option continues to have no effect. – Mahmoud Al-Qudsi Oct 4 '15 at 14:22
  • 1
    This worked for me after upgrading to MacOS Sierra. – tlatkovich Sep 22 '16 at 15:47
1

What worked for me:

1) disable and unload the AFS kernel extension which I no longer wanted anyway - leftover from time long past.

cd /Library/LaunchDaemons/ launchctl unload org.openafs.filesystems.afs.plist rm org.openafs.filesystems.afs.plist

2) restart

  • I have never installed AFS :( – Mahmoud Al-Qudsi Oct 5 '15 at 19:52
  • 1
    Oh, someone is listening! I watched /var/log/syslog and saw this: Oct 5 14:09:54 dragonfly AFSBackgrounder[892]: Task failed. That gave me the clue, as home machine did not suffer broken screen saver as did my work machine, and only work machine had AFS. So check syslog when you try to activate the hot corner and see if anything interesting pops up. – Steve Oct 5 '15 at 21:05
  • Unfortunately my log showed no errors when I moved the mouse to the location that was supposed to trigger the screensaver, despite much effort. The change-restart-change-back approach is the only thing that resolved the problem. – Mahmoud Al-Qudsi Oct 22 '15 at 21:53
  • Just upgraded to OS X 10.11.2 and my screen saver hot corner broke again. I found another AFS remnant - a pref pane - which I used to disable AFS entirely. Then I removed the pref pane and restarted. Now the screen saver hot corner works. Again I used syslog, but the error did not coincide with any attempt to start the screen saver, it was a timed event. What I'm saying is to not necessarily expect an obvious error, but to scan the log for unusual third party activities. – Steve Dec 10 '15 at 20:59
  • Like you, I upgraded and it broke again. No AFS, no console errors (again). I'll need to do the disable, restart, enable, restart approach again :/ – Mahmoud Al-Qudsi Dec 10 '15 at 22:36
1

Seb's answer didn't work for me (running macOS Sierra 10.12.6). Changing the hot corner to something different didn't work for me but changing it to something more SPECIFIC did.

  1. Changed the hot corner of "Start Screen Saver" to "Disable Screen Saver" and click [ OK ]

  2. Then roll over the hot corner (of course nothing happens)

  3. Click back into [Hot Corners...] options, change it back to "Start Screen Saver" and click [ OK ]

  4. Screen Saver should activate as expected

0

Had the same issue. Try to reboot. Helped for me.

0

I had a similar problem after my clean upgrade to Sierra with migration of my personal files. I tried all of the suggestions above and elsewhere with no luck. In the end I ran across something somewhere that got me looking at ~/Library/Preferences plists. I discovered a bunch of old lockfiles. Removing the lockfiles and rebooting fixed my hot corners problem, my "dock preferences get reset at reboot" problems, etc.

If nothing else works, check ~/Library/Preferences for lockfiles, remove whichever ones you wish, and reboot. Ex:

-rwxr-xr-x  1 username  staff  0 Oct 15  2012 /Users/username/Library/Preferences/MobileMeAccounts.plist.lockfile
-rwxr-xr-x  1 username  staff  0 Mar 16  2012 /Users/username/Library/Preferences/cc.arduino.Arduino.plist.lockfile
[…]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .