5

I have a MacBook Air from Mid-2013 and the new iPhone 6S, both running their newest OS (Yosemite and iOS 9).

According to Apple, AirDrop only works on these machines:

Use AirDrop between iOS device and Mac: the iOS device has to be running iOS 8 and has to have a Lightning connector. the Mac needs to be running OS X Yosemite and needs to be a 2012 or newer iMac, 2012 or newer MacBook Air, 2012 or newer MacBook Pro, 2012 or newer Mac Mini or Late 2013 Mac Pro. (Source: 9to5Mac)

So technically it should be compatible, and I also met the necessary other requirements:

Once you have met compatible hardware and software requirements, the devices do have to have Wi-Fi and Bluetooth turned on, even though it works without internet access.

I even put them on the same WiFi network, with working Internet access.

I know that I have the "new" AirDrop on my MacBook Air, since it gives me the option to look for "older Macs". In fact, if I click on that option I can connect to my Late-2009 iMac without a problem, as long as both are on the same WiFi network.

I also tried activating AirDrop "for everyone" on both the MacBook Air and the iPhone but it still didn't work.

Does anyone have an idea why not, or what else I could try out?

  • I never got it to work. Using iChat for file transfer. – CousinCocaine Sep 28 '15 at 11:22
  • Which Macs did you try AirDrop on? – comfreak Sep 28 '15 at 12:10
  • OS X 10.9 and OS X 10.10. On MBPr and MacMini – CousinCocaine Sep 28 '15 at 12:11
  • So both are supported according to Apple's description? – comfreak Sep 28 '15 at 12:12
  • Yes they both do. – CousinCocaine Sep 28 '15 at 12:30
1

I also suffered from the same problem, although wifi + bluetooth are in the on state in both devices, finder window was empty.

But when I tried to send a photo from my iphone to macbook, suddenly my iphone identified & shown in finder.

My devices

  • MacBook Pro 2012 Mid -El Capitan (10.11)
  • iPhone 5 - iOS 9.3.1
0

Since you have an "older mac" around, is it one that's still able to use AirDrop? Does that one connect with your iOS device?

Have you tried force-restarting the phone? Both devices are supported, if it doesn't work, I'd test the phone with another phone, and the computer with another device as well. See where the breakdown is.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .