3

Today I found my iPhone 4 (iOS 7.1.2) is unable to connect specifically to any Google service (Search, Google.com or YouTube) when on Wi-Fi.

Any other website will load.

I get the message "Safari cannot open the page because it could not create a secure connection to the server".

All other browsers show a similar error - Google Chrome says: ERR_CONNECTION_CLOSED.

All my other devices on the Wi-Fi network work with Google ... my Win8 PC, my Android Tablet and Smart TV.

I have tried resetting network settings but with no luck.

Anyone else had this problem?

  • Any wifi, or just one specific wifi connection? – Tetsujin Sep 25 '15 at 16:36
  • 1
    Same issue here on both an iPad 2 and iPhone 4S running iOS 7.1.2. I thought it might be related to the trusted root certificates, so updated the iPad to iOS 9 - still had the same issue though. dordio's answer (changing DNS settings) solved it for me. – Alex Warren Sep 25 '15 at 22:35
1

It might be related to the DNS on the iPhone.

Go to Settings -> Wi-Fi -> And Connect to your home Wi-Fi Network

Now:

  • Touch on the "i" icon on the right;
  • Where it says DNS edit the value for: 8.8.4.4
  • Go Back to the Wi-Fi networks listing and wait to confirm that the blue tick appears on the left.

This DNS address is from Google, so it will work with everything Google related but also outside of Google universe. I've set that address for all my DNS addresses in every machine I use and never had a problem.

-1

Same appeared here for me in Sydney, Australia, less than 20h ago. Four cases:

1) Safari on Two iOS7 devices, iphone 4S and iPad 3, can't load Google pages (" ... can't create secure connection ...") when connected to my home WiFi. All other sites (non-Google) that I tried load ok over the same WiFi.

2) iPhone was then switched to 3G (cell network) and Safari loads Google stuff, no problem.

3) two other devices, iPhone5 and iPad4, both on iOS8, load Google stuff OK over the same WiFi.

4) iPod Touch 2ndG iOS4 - Safari loads Google OK over same WiFi.

All devices have DNS set same way and nothing was changed on those devices in that respect for long time nor iOS has been updated for quite some time.

And tried just now, 20h later, iOS7 devices load Google stuff OK! haven't done any changes on my devices nor WiFi.

Can't explained what happened. But just for the record.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .