0

I've got an HP monitor (specs here) that is supposed to display natively in 1080p. I've used it for years in this setup no problem.

Last night I upgraded my Mini to a newer model, and when it was starting up I realized that I didn't have the HP monitor plugged in, just the secondary monitor, so I connected it via the HDMI port, as I always have.

For some reason, the HP monitor is now thinking that the edges of 1080p are an inch off the screen in every direction when told to use its native resolution in the Displays control panel. If I use the other options below it (1080p, 720p, and 1600x900), it just gets increasingly worse, only showing a quarter of the actual screen. Restarting has not fixed this.

Today I was plugging it back into the old Mini to help get it set up for a coworker and it's working normally again.

I'm completely at a loss at this point for why it's misbehaving. The only way to get it to display at the proper size is to slide Underscan slider halfway across in the display's settings, but that causes other issues due to irregular pixel sizes, etc.

Is there any way to "unregister" this monitor's settings and have it detect them again, perhaps? Or some other way to get it to detect it properly?

  • SMC reset & start over, with just the main monitor first... & no hot-swapping ;-) – Tetsujin Sep 25 '15 at 16:15
1

Tried doing an SMC reset, followed by a PRAM reset; neither worked. Tried switching ports on the mini using an HDMI-Mini DVI dongle and starting up as the only connected monitor on this new setup; no change.

In the end what did work was switching to the monitor's DVI port and using a DVI-HDMI cable that came with a new monitor I'd picked up recently. Screen now registers at the appropriate size and without scaling.

  • Planning to accept this answer for now since it technically fixed the primary issue (the display's native resolution is fitting to the screen properly again), but I'll gladly change the accepted answer to another if someone can come up with a way to get the system to forget this monitor exists and start registering it properly on its HDMI port. – Kaji Sep 27 '15 at 1:56
0

I've used an HDMI screen as a monitor for my Mac Mini for years. I can tell you that in my experience, you sometimes need to enable overscan to get the display to go edge to edge. Otherwise, you get black bars around the edge of the screen.

  • Thanks for the suggestion, but the issue is that it's overscanning by default and I can't get it to stop. I can force an underscan, but that's been causing a loss of image quality. – Kaji Sep 27 '15 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .