0

I am running OS X Yosemite 10.10.5 on a Mac Mini system with two monitors. When I maximize an application on monitor 'A', monitor 'B' then goes black while that application maximizes to fill 'A'.

Why the heck is this happening? How do I fix it?

Thanks!

3

Why?
Personally,. because I don't think they ever thought it through properly. There's a lot about fullscreen that's like that.

The fix is possibly System Prefs > Mission Control > check Displays have separate Spaces

enter image description here

The better fix is don't use fullscreen, use Alt/click on the green button to maximise instead.

5
  • 1
    Thank you! This may sound silly, but you have made my night. Now my code development may exist peacefully now, with Firefox open... ;)!!!!!
    – J-Dizzle
    Sep 25 '15 at 5:10
  • 1
    Nothing silly about having a comfortable workflow :-) I'm a big Spaces user myself - but fullscreen really messes Spaces up. See apple.stackexchange.com/questions/179376/… for some of my other ramblings on the subject ;)
    – Tetsujin
    Sep 25 '15 at 5:14
  • I believe OS X El Capitan will be changing some of this. Sep 25 '15 at 10:21
  • I hope so, but I'm going to wait for the .1 release to see if it fixes some other things I found even more irritating in the GM ;)
    – Tetsujin
    Sep 25 '15 at 10:22
  • Alt-click is a lifesaver! I disabled separate spaces so open applications can span multiple monitors. But the unexpected side-effect was that non-focused screens go black when you maximize an application. As a long-time Windows user the default behavior was confusing.
    – Ken Palmer
    Jan 4 at 21:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .