Whenever I need to install an app using the package installer, there will be a prompt asking for admin user's name and password. How do I temporarily turn this feature off, so that any package can be installed automatically?


You'll want to go into your System Preferences, and into Security & Privacy

enter image description here

Then unlock - if needed - the lock on bottom left, and select "Anywhere". The computer might ask you for your password.

enter image description here

When you're done, you should be able to open and install many .DMG installers without being prompted for a password.

When you are done, you can revert these settings as they are a good security to prevent third party apps from installing automatically on your computer.

  • Strangely, everything in the general tab is greyed out even after i unlock it. Any idea why and how to fix it? – Fermat's Student Sep 25 '15 at 0:03
  • Could you try repairing your permissions in Disk Utility, and restarting (while leaving the lock open), and trying again, see if you still run into this greyed out problem? – MicroMachine Sep 25 '15 at 0:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .