1

Can't explain it, my official wired Mac Keyboard that came with my iMac (20-inch, Early 2009) currently running OS X Yosemite 10.10.5 (14F27) has a backspace key that suddenly stopped working.

I've tried the ol' NVRAM/PRAM and SMC reset but that hasn't solved it. I've also tried unplugging the USB port and trying a different USB port, still nothing.

As far as I can see, its only the backspace key thats been affected.

Any clues?

  • Have you tried a keyboard that does have a working backspace key? You also might want to type on the key rapidly, (as if you were doing a trill on a piano key,) to perhaps crush into dust a small crumb or something else that may be causing the key mechanism to malfunction by obstructing the electrical contact. – IconDaemon Sep 24 '15 at 23:41
  • Seems like it's a hardware issue. Tried the same keyboard on a different Mac, same issue. Removed the actual keycap to clean it out, even pressing directly on the rubber below the key doesn't cause it to work. – paperclip Sep 25 '15 at 7:47

You must log in to answer this question.

Browse other questions tagged .