I was trying to install drivers for my NEC USB 3.0 PCI card. ( propably http://sourceforge.net/projects/genericusbxhci/files/ or https://github.com/RehabMan/OS-X-Generic-USB3 )

I rebooted my mac into kext-dev-mode=1

then i typed: sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

GenericUSBXHCI .kext was enabled. Two other .kext too.

After restart - my usb 2.0 and usb 3.0 was working fine! Pendrvive was copying files very fast.

But unfortunetally magic mouse won't connect, so i restarted Mac Pro.

Now, booting is frozen. Sometimes at 1/3, sometimes at 1/2 I can't enter the Recovery Mode or Single user mode.

I was trying every possible ctrl+r, windows+r, alt+r, shift combinations on my logitech usb keyboard, but Yosemite just won't boot.

After freeze, computer reboots, and white screen of death appears. Over and over again.

I have Yosemite installation disk image on my pen drive and Mavericks installator on my external hdd, but i wasn't able to start it.

I don't event know if efi sees my keyboard.

Maybe keybindings are the problem, cause i normally use oldshool DIN-5 mechanical keyboard from 1980' But the shortcuts from this keyboard won't work too.

What can I do to enter command line or repair .kext's ?

I have no other mac/pc to connect the hard drive.

UPDATE: First success: Linux Mint booted and it's working fine. I can read my Mac SSD drive! So i assume that hardware is all right. Even magic mouse is working under linux.

I have discovered installer.faliurerequests file on Mac drive. It says: Operation fsck target CrashAtProgress 0

After rebooting from linux to Os X it was working like 10 minutes, artifacts appeared on the screen, and then crash again. Next time it was working only 2 minutes... and now i can't boot it again.

  • I am commenting as not 100% sure. Doesn't Yosemite offer a emergency boot image? Startup holding option key and boot into that? – JoeTaxpayer Sep 24 '15 at 18:15
  • i tried every possible boot shortcut. It doesn't change anything! Sometimes it was booting very long (to 1/2 of the bar), sometimes it was restarting very fast after boot. But i wasn't able to enter any emergency image or even boot disk selection. – Lukasz B Sep 24 '15 at 18:21
  • Wow. After 2 hours of rebooting... it just boot into Os X. But now... how to make sure, that it will be fine after next boot? After i plugged pen drive in - my mouse stopped working. – Lukasz B Sep 24 '15 at 18:40
  • things get worse... mac rebooted during normal work... and won't turn on again – Lukasz B Sep 24 '15 at 18:56
  • All I know is I own a 3.1 and a 4.1 pro and when upgrading, the USB 3.0 card had s warning it would only work in 4.1. I don't know if that is the problem you are having. – JoeTaxpayer Sep 24 '15 at 19:09

The problem was graphic card! GeForce 8800 GTS was making all that problems. I have replaced it with Radeon 5770, and everything is fine!

Funny thing is, the USB 3.0 really has something to do with wireless magic mouse! USB 3.0 somehow interferes with bluetooth 2.4GHz waves! It can be repaired with... aluminium foil! I've covered bt module with aluminium foil, and mouse is working fine again!

Everything solved

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.