5

My problem is that Spotlight shows no results from internet sources (Wikipedia, iTunes Store, etc.). I've reindexed my drive twice, cleared all the caches, and reset the NVRAM. Still not working. I have everything in Spotlight preferences checked.

But when I search for a stock there's no results. Funny thing is, if I try it in Safari it works just fine.

What's going on?

The output of launchctl list | grep Spotlight is

465 0 com.apple.metadata.SpotlightNetHelper 466 0 com.apple.Spotlight

This might be a duplicate of the following question question, but there's still not a satisfactory answer (and that question asks about Yosemite, not El Capitan):

  • Same here. Identical configuration running El Capitan GM. Every time I try, i see this message in Console: Spotlight[318]: XPC connection was invalidated – user149346 Sep 30 '15 at 15:34
  • In Terminal.app what is the output of this command: launchctl list | grep Spotlight – l'L'l Oct 22 '15 at 21:44
  • @l'L'l updated. – Max Isom Oct 24 '15 at 0:20
  • @codetheweb: The results of the command shows that the Spotlight helper processes do seem to be running (which is normal). You could possibly try to launchctl unload then launchctl load each of those processes which would essentially restart them. Also, which country are you in? The reason I ask is that can affect the ability of Spotlight to do internet searches. – l'L'l Oct 28 '15 at 8:35
  • @l'L'l I just updated yesterday, and it seems to be fixed. Not sure what happened. Thanks for your help. – Max Isom Oct 28 '15 at 20:13
1

This seems like the sort if thing I would update to the latest OS version (you appear to be 10.11 - the initial and possibly most buggy release possible) and then retest with 10.11.6.

If you still have problems - make a new user account, log out of your current account and then see if a new account with default settings can search.

Unless you are on a corporate network that blocks some outbound connections - this likely is an issue with the settings file or an odd bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .