6

I'm trying to clean up some space on my iPhone, for this I need to sync it with a new Mac. The Mac doesn't have the files on the device, so sync will erase everything on the device. So I want to backup first, and then sync. But the backup complains there's not enough space (where? Mac has 55GB free). Errrrr. Pretty stuck here!

This is the message I get from iTunes (12.3.0.44) when trying to manually backup my iPhone 4S (iOS 8.1.2) to my Mac (Mac Book Pro Yosemite 10.10.5).

This is what happened until now:

  1. Last sync was on another computer (old Windows laptop), this is the first time trying to backup/sync on this Mac
  2. iPhone is full (I want to backup the data and then to cleanup)
  3. Mac has 55GB free space
  4. Backup wouldn't start, reported not enough space (a different message!) to sync
  5. Cleaned the lockdown folder as suggested by Apple
  6. Backup had started but reported an error about a "session could not be started"
  7. Restarted the device while connected to Mac (as suggested on some forum)
  8. Backup had started but reported this message ("iPhone XXX cannot be synced because there is not enough free space to hold all of the selected items.")

Any ideas?

EDIT 2017: I no longer use this phone, eventually I didn't find a solution.

  • delete any iOS update files first, then any large apps you can manage to potentially lose data for, sat navs etc are often large – Tetsujin Sep 24 '15 at 15:06
  • @Tetsujin Thanks! Are the update files stored on the device? I don't get the message - where is the missing space, on my Mac or my iPhone? – krulik Sep 24 '15 at 15:08
  • I'm pretty sure iOS 9 or 9.01 will be stored on there somewhere - see Settings > General > Software Update – Tetsujin Sep 24 '15 at 15:18
  • 1
    "So I want to backup first, then sync" Backup first before sync won't help you keep music files. You didn't say that's your expectation, but just to be clear... Music is not part of a backup. – Tyson Sep 24 '15 at 17:16
  • 1
    Next time buy an Android. You can just plug in a USB cable and be happy. All this iTunes nonsense and custom cable is madness – Mateus Ribeiro Nov 7 '18 at 15:11
2

When you start syncing your iDevice in iTunes and then you get this annoying message (especially when it tells you it needs like 1.4MB and there is 300MB available?!): 'The iPhone/iPad “iPhone(insert name)” cannot be synced because there is not enough free space to hold all the selected items'. What do you do?

Basically the problem, in many cases, seems to be that iTunes thinks it has too many updates to install on your iPhone/iPad and it isn't smart enough to load them one at a time when there's not enough space to do them all??

Fortunately it can often be side-stepped by just taking your iPhone/iPad and clicking on the App Store app, then tapping on the Updates tab, and then tapping on 'Update All' at the top right. If that complains that there's not enough space you can let do some updates then try again (and again) and will update the rest of the apps. Then the sync should be fine with iTunes.

  • This will still probably fail if you're trying to update any large apps like iMovie or Keynote. I had that happen, so I deleted them from the phone until after I could get it synced again. – Kent Aug 29 '17 at 13:17
0

I experienced a similar problem. So what I did was connect my iPhone 6S to the iTunes with which it was earlier synced. From there I deleted all the music, movies, and photos from my iPhone. After deleting the media I connected my phone to my new mac and it synced perfectly without showing that error message again. Hope this works for you as well.

0

I fixed my issue today. Our iPhone 5 with 32 gigs had no issue syncing or backing up; however or iPhone 6 with 128 gig was causing the "lack of disk space" error message. I emptied my trash bin freeing up 30 gigs but still not luck.

After doing some research, I deleted the last backup of the iPhone 6 as some users said it may be corrupted. Once I did that, I was able to do a backup on Iphone6. Then I was able to sync with no issue!

Hope this helps some of you. Good luck. Just disappointed that Apple does not help at all!!!!!

0

I was experiencing the same problem:

  • iPhone Xs Max 256 GB with 171 GB free
  • MacBook Pro with 300+ GB free

iTunes told me not enough space to backup.

And eventually was able to fix it.

I thought 256 - 171 = 94 GB would be needed as a maximum. Minus some iOS system data that wouldn't need to be backed up. My previous backup on my MacBook Pro using iTunes was 81 GB so that indeed looked correct. With an efficient process that would make sense.

But it wasn't

Tried all kinds of different things to fix it. Enabling/disabling encrypting. Changing encryption password. Removing previous iTunes backups. Enabling/disabling iCloud backups. Using different cables. Rebooting. Disk Utility First Aid (in Recovery Mode). DaisyDisk cleanup of hidden space. Disabling Time Machine automatic backups and removing the Time Machine disk. Deleting all local Time Machine snapshots.

None of these steps individually enabled me to backup without an error message.

In the end what actually fixed it for me: - I removed as many files as need on my MacBook Pro to get up to 350 GB of free space. - Retried iTunes backup. It worked!

So apparently in my case I needed even more than 256 GB of free space to perform the iTunes backup. The 300+GB I started out with wasn't enough.

Reason why? I don’t know. It did work.

An hypothesis could be that because your iPhone is encrypted it first copies an entire 256 GB image of your iOS installation to your Mac and then needs extra free space (maybe up to your actual backup file size) to create the actual final backup file.

Give it a try.

0

I just ran into this issue with my 128 GB iPhone XR in 2019. It had over 50 GB free but suddenly iTunes was saying that it needed another 1.3 TB of space to fit my synced data! This was pretty unreal since nearly nothing had changed between syncs (and in fact only a week had passed). I was very fortunate to discover that some of my very old m4a files were unreadable by iTunes. It had determined that they were each 768 hours long and refused to play. For some reason this happened to 3 of my albums, all by one artist. Several of these songs had been synced to my iPhone previously without any issues, and a few had even been played just a few days prior.

To my knowledge, nothing else in my library was affected. Once I removed those files from my library, the sync ran without issue.

Unfortunately, I just got lucky in finding these files. I don't have a sure-fire method for locating them yourself. You could try viewing your library by Songs view, ensure it displays the Time and Size columns, and sort by each of those columns to see if anything weird shows up. Also, try singling out your m4a files before suspecting mp3's.

What's even stranger is that the m4a files are actually fine. They play in VLC without complaint. I tried removing them from iTunes and re-adding with no luck. My final solution to get the files playable again was to use an online converter to change them from m4a to mp3. Transcoding lossy to lossy is never ideal, but it worked. I regained these songs in iTunes and my phone syncs without complaint.

This was in Windows 10, iTunes 12.9.4.102, iOS 12.2.

-2

figured it out, you have to uncheck the encrypt iphone backups. give that a go and click back up!

I tried this and it seems to be working for me - I have NO idea why, but a dozen other ideas didn't work at all. I untucked the 'encrypt' box, and tried sync again, and now it's proceeding as usual. To be clear, I had the error where there was plenty of room for the back up and sync (asked for 1.1 Mb, said I only had 5 Gb) - but then it was saying that there wasn't enough room. Once it's synced, I'll retick the box and hopefully it will all be back to normal.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Your answer lacks certain information to help answer the question. Please take some time and edit your answer so it would be useful. – Behdad Dec 14 '15 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .