I upgraded to OS X 10.11 El Capitan Gold Master last week, and ever since I've been having weird time issues. All of Apple's apps think the time is the correct Pacific Time zone that I'm in, but third-party web apps and other tools don't think the time is correct. Among them are Slack, Intercom, and a few other team communication tools I use.

I then resorted to Terminal, using the date command. Unfortunately, I found an issue: It reports the time is seven hours ahead of what it's supposed to be. I've tried a lot of random troubleshooting, looked in Console for errors, set the time manually, and all that other boring nonsense. I have no idea what's going on. I would love help troubleshooting this if you guys have any suggestions at all.

  • What remission does data say it is – mmmmmm Sep 23 '15 at 21:49

I have a simular issue. Only on start up/reboot MBP defaults to PST. I go to Preferences and as soon as I unlock padlock it reverts back to EST.

  • That's very strange. Mine was fixed by reinstalling the OS. But gosh, that's a bit much! – Jacob Oct 2 '15 at 18:08

Have you tried setting the date manually using the Terminal?

Something like this:

date {month}{day}{hour}{minute}{year}

Where every bracket should be replaced by a two digit number. So today's date (24th September 2015 00:05) would be:

date 0924000515

As seen here.

  • I already tried that and it simply changes the time in the menu bar to be incorrect. – Jacob Sep 24 '15 at 2:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .