8

When I get a call through FaceTime, it switches away from a full screen app/video I'm using. I don't want to turn it off, because getting calls on the computer is useful, but I don't want it to automatically switch what I'm doing.

6
  • 1
    This is actually a really good question. In theory, if you define that the FaceTime app has a Banner or Alert type of notification, it should do the trick. Alerts (which require an action to be dismissed) would exit the full screen app, whereas Banners would only present them self and be dismissed if no action was performed. – dordio Sep 23 '15 at 23:45
  • @dordio I will try that. Could you answer so I can upvote? – Hassan Sep 24 '15 at 14:12
  • 2
    @dordio Oh I see. I really wish Apple would fix this, because it's actually extremely annoying... – Hassan Sep 24 '15 at 14:15
  • 1
    Three years on, same problem. – Hassan Nov 20 '18 at 22:26
  • 1
    Same problem in 2020 – Sora Jan 12 '20 at 23:17
1

I did some testing and the short version is you have to open your Facetime app and then minimize it. (command + M) or hide it. (command + H) Minimizing turns the camera off, hiding leaves the camera on.

Unlike Messages which doesn't have to process anything, Facetime has to open the app up, setup the window, and then process the call. Since it has to setup the window when there are no windows open, it blinks to the default desktop tile for this, the first tile if it is unassigned and an app is using a designated desktop tile, and then allows the call to go through. If you have already opened a window and just minimized it, then this doesn't have to occur, and it will process the call right away.

From what I found, if you have it minimized/hidden and receive a call when watching Youtube/etc. full screen, it will pop up the notification bubble like Messages does and allow you to click on it to answer. In some cases, if you click on the bubble itself and not the answer button, then it will tile shift still. It seems to do this as well when the cancel call is pushed, but I need to test more. I also haven't tested this when receiving an actual Facetime call as compared to a regular phone call, so nothing guaranteed there.

Something that will help is to set in System Preferences -> Users and Groups -> Login Items and add Facetime to this, then minimize whenever it opens.

1
  • Can't believe you answered this five year old question, I really appreciate it. I'm mostly on Linux these days but this workaround will no doubt help whoever stumbles on it. – Hassan Oct 11 '20 at 19:35
1

Unfortunately there is no way to prevent an incoming Facetime call from interrupting your workflow.

Apple has a document that outlines what can be configured for Facetime on a Mac.

https://support.apple.com/guide/facetime/change-preferences-fctm35545/mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .