14

All of my email accounts seem to be working just fine, and in the main inboxes, emails from VIPs are marked with stars next to the senders' names as usual. The issue is that all of the VIP-specific mailboxes show up as having 0 messages, even the big "VIPs" one (the one that contains mail from all VIPs). Un-starring and re-starring the contacts doesn't fix anything. I can still search for the messages by the contact and find everything, it just doesn't show up in their VIP mailbox in the sidebar.

Another helpful observation: Turns out VIPs work fine on my two rarely-used email accounts (Verizon and iCloud) that aren't Gmail. I knew OS X didn't like Gmail, but I've never seen this before.

This has been going on for as long as I can remember on El Cap, from the first public beta all the way to the newly-released 10.11.1 public beta. How do I fix it?

  • 1
    I haven't had any issues with the VIP on 10.11 - have you tried making a new user account and testing with one mail account there? I don't use gmail with Apple mail, though so I don't want to answer either way... – bmike Sep 22 '15 at 4:14
  • It is a beta for a reason.... – user14492 Sep 22 '15 at 12:21
  • Threads (conversations) don't work properly either; one reason I went straight back to Yosemite. – Tetsujin Sep 22 '15 at 16:30
28

I just got this to work after an annoying 2 months!

  1. Select a single VIP Mailbox
  2. Go to View then Sort By then select All Mailboxes
  3. Go to the main VIP Mailbox and all should appear.

If that works you can then try changing the sort to go back to Inbox only.

  • I just love when a series of random actions manages to fix something. Thank you so much!!! – user24601 Sep 22 '15 at 14:55
  • Sir, your answer is gold. I've been updating to the latest beta versions of ElCapitan and was frustrated the bug is here. I used a lot the VIP inboxes. Thank you. – Cristian Holdunu Oct 16 '15 at 6:38
  • What is met by "Select a single VIP Mailbox" I don't see any VIP mailboxes. On MacOS Sierra at least, there is no All Mailboxes in the View->Sort by Thanks – Robert J Berger Oct 16 '16 at 21:26
  • This bug/fix still applicable to Sierra, it would appear... just used it to fix a similar issue. – calum_b Apr 13 '17 at 23:02

You must log in to answer this question.

protected by Community Oct 2 '15 at 14:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .