3

I'm trying to backup my iPhone before upgrading to iOS9. Right now it's running iOS 8.4. After pressing 'Back Up Now' button in iTunes I'm getting this error message: 'iTunes could not back up the iPhone ... because an error occured'

enter image description here

I tried all steps from this official Apple's document: https://support.apple.com/en-us/HT203271 (including restarting Macbook, iPhone, I tried another Macbook, different USB ports etc).

Any ideas how to fix this? I don't want to upgrade to iOS9 without backup.

UPDATE:

I upgraded my iCloud storage and tried iCloud backup. It failed with 'The last backup could not be completed' error.

UPDATE 2:

Probably I found the source of my problem. When I go to the Settings->General->Usage->Manage Storage I get list of installed applications. There is an empty application. Check this screenshot. Its size is 50.7Mb.

enter image description here

I can select it and I see such screen:

enter image description here

I can press 'Delete App', and there is no name for this app (null).

enter image description here

After confirmation this app goes from the list, but if I go back from Manage Storage and return there, it appears again, so this application can't be deleted. I tried hard reset, but this application stays in settings event after it.

My iPhone isn't jailbroken

  • Just to make sure: When you connect your iPhone to iTunes are you attempting to back it up to the computer or to iCloud? Like this: imgur.com/wegUJOn – dordio Sep 24 '15 at 10:39
  • @dordio, I'm attempting to back it up to my computer, using 'Back Up Now' button: imgur.com/BMmseAd – Vitaly S. Sep 24 '15 at 11:15
  • Ok. Make sure you have the latest iTunes version and also try disabling Find My iPhone during the back up process. – dordio Sep 24 '15 at 11:27
  • @dordio, The problems exists even after disabling Find My iPhone... I'm using iTunes 12.3.0.44 – Vitaly S. Sep 24 '15 at 16:30
2
+50

I faced the same issue on my phone: unable to backup, neither to iCloud or through iTunes. I found some few posts, most notably this one and this one .

Basically your on the right track: backup fail because of one or more zombie app(s). Apps that were deleted but are still there... :(

The only option seems to be to find out what app is causing this, and reinstall it, check your backup is working again, then delete it (hoping this time it will go away for good, leaving a proper state for backup to keep working ) !

To find out what is your zombie app, you'll have to find out based on whatever information you have about it. Some like me still have the app icon showing in Settings->General->Usage->Manage Storage, which make identifying pretty straight forward. Unfortunately, in your case you'll have to find out what app of 50.7MB and version 23.0 you recently deleted. To help you in your quest, you could look into:

  • your memory ;)
  • in the App Store of your iPhone, in the list of purchased apps, look for those not installed that could match. [added base on comment below]
  • in iTunes, in the iPhone sync screen, app tab, the app listed as installed on your phone while you do know you removed it...
  • in your iTunes Library, App folder, in list view so you can sort by size
  • your iPhone logs, using Xcode (that's the geeky way !). see the second post listed above for a detailed how-to.

Hope you'll get to it. Good luck !

Side note: I would have added more links, but being a rookie on 'Ask Different', I'm limited to 2 external links...

  • I was able to create a backup! :) More details soon – Vitaly S. Sep 25 '15 at 16:44
  • A bit more details: you always can check list of purchased, but not installed applications in the 'App Store' app. Fortunately problem was with application with 'rare' version number (23.0). I thought it was some application from Facebook (e.g. Pages, because I don't use it). But I found other application with 23.0 version and tried to install it. Unfortunately reinstall stuck somewhere at 60%, but it was enough to make backup and install iOS9. After restart the problem application disappeared! – Vitaly S. Sep 25 '15 at 20:12
  • Glad it helped ! I edited the answer to add your way of identifying the zombie app. Happy iOS 9 ! ;) – CuriousFab Sep 28 '15 at 8:37
  • 1
    No zombie app here, but looking into the log mentioned in the first link revealed something about a Pandora playlist unable to be moved. reinstall pandora all good now able to backup thanks! – happytime harry Oct 27 '15 at 2:51
1

I basically had the same problem and asked about it in this thread. The difference was that there were no apparent 'zombie' apps. A more careful investigation of the device log in XCode identified the Whatsapp database/preferences/… as the culprit. Deleting and reinstalling Whatsapp cured the problem for me.

0

It's very wise to not wish to update without a backup. I'd try disconnecting your iPhone from your computer, then restarting your iPhone 5S by holding the lock (power) button and home button together until you see an Apple logo appear. Don't worry, it won't wipe your iPhone or change any content or settings, but it might just solve your problem.

READ THIS!!!: Ensure that your iPhone is not connected to iTunes while you restart it. You might accidentally put it into Recovery Mode and then you really will lose data. So restart it then when the lock screen appears, unlock your iPhone and then try to back it up again.

  • Your steps don't help :( – Vitaly S. Sep 22 '15 at 9:21
  • BTW, I can't make backup using iCloud backup too :( – Vitaly S. Sep 24 '15 at 10:27
0

All sorts of issues might be causing the backup error. I was facing the same problem with an iPhone 5 also running iOS 8.4. After reading the Apple forums, the following worked for me and I've solved it!

1. Plug the iPhone to USB cable

2. Turn off "Backup to iCloud" in iTunes by choosing "Backup to this computer"

3. Sync

4. Go to iCloud and delete all previous backups (additional instructions bellow)

5. Turn on the "Backup to iCloud" option in iTunes again

6. On the iPhone click Backup to iCloud

! Important: Depending on how much data you need to backup, this might take some long time, be patient and wait.

Step 4. - additional instructions

Depending on your iOS version you might have 2 iCloud Backup locations, make sure you delete the previous backups in both locations and then do a manual backup.

iCloud location 1: Settings > iCloud > Storage and backup > Manage storage

iCloud location 2: Settings > General > Usage > Manage storage

Weirdly, some users have reported that the following trick might solve the backup error. You might want to give it a try after following the instructions above.

  • on iPhone, go to Settings > iCloud > Storage and backup
  • Click Manage storage on the iPhone (or whichever device is having issues)
  • Under Backup options, uncheck "Camera roll"

In iTunes try to manually "Backup to this computer" and see if that works. If it works, you can check the "Camera roll" option again on your device and the backup should still work! Perhaps this little trick can solve the issue.

/---------------*--------------/

If the steps and instructions above did not help, the following alternatives perhaps will guide you in the right direction:

-- Before anything else --

  • Make a Backup of your iTunes Library
  • Make a Backup of your device's Backup folder (The iPhone backup is stored (assuming Mac) under: /Users/Myself/Library/Application Support/MobileSync/

--> replace Myself with your actual Mac user name

How to find the iPhone Backup folder (assuming Mac)?

Go into iTunes preferences under Devices tab, ctrl + click one of the backups and select show in finder.

or

Open a new finder window and in the menu bar click Go to Folder and type in /Users/Myself/Library/Application Support/MobileSync/

--> replace Myself with your actual Mac user name

Both ways will open up the device's Backup folder in finder, make a copy of all the folders you find within the Backup folder to the desktop.

  • If all necessary backups are made, you may now Completely Uninstall iTunes. The ordinary uninstall process will not remove iTunes library nor the devices (iPhone) Backup folder (which you should already have made the backup as mentioned in the first steps as a precaution).

  • Delete (Move to trash) all Backup folders you have located under: /Users/Myself/Library/Application Support/MobileSync/

  • (Clean the trash)

  • Restart the Mac and download the latest iTunes version, install it, restart the Mac again.

  • Connect your device in iTunes and try to make a manual Backup by choosing "Backup to this computer" option

  • Sync

If the Backup process turns to be successful, you may now have newly backup data within your device's Backup folder under: /Users/Myself/Library/Application Support/MobileSync/

From this point you could proceed on setting up the iCloud Backup again under iTunes.

If all those steps failed, continue to nail down the possible cases why this error might be occurring etc. You might also want to try a different usb cable if available.

Good Luck!

  • Your steps don't work too :( – Vitaly S. Sep 24 '15 at 16:12
  • Sorry if it didn't helped you. I'm sure you must have tried all sorts of workarounds. Anyway, I'm updating the answer with a few more alternatives I recall I have tried but I've not mentioned here. Perhaps that might help. Let's see. Good luck. – Adriano Monecchi Sep 24 '15 at 16:25
  • Thank you @Adriano. I added some details to my question too – Vitaly S. Sep 24 '15 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .