I have updated to Xcode 7 from App Store. And now when ever I run an application or directly start the simulator from Xcode, i got an error Error Returned in reply: Connection Interrupted.

enter image description here

I searched on internet, but did not found any solutions. Kindly advice about this issue.

  • 1
    Did you restart both the computer and the phone already?
    – nohillside
    Sep 20, 2015 at 7:20
  • I did everything. I restarted my laptop and still it did not worked. I am not using phone to test my app right now. I am using simulator. Sep 20, 2015 at 7:27
  • OK, i restarted my machine again and it worked now :). Not sure why it was not working before. Thanks for your advice. Sep 20, 2015 at 7:48

1 Answer 1


I had the same problem, and I found at the end that I had 2 simulator windows running at the same time. I close both of them and Xcode, and the problem was solved. I didn't need to restart my machine.

  • I had to remove the simulator from dock preferences to run. I didn't need to restart my machine.
    – sai
    Apr 27, 2016 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .