1

This question already has an answer here:

I would like to disable the accent characters options you get when you hold down keys.

I have always used holding keys to repeat letters but all of the sudden it shows special characters and won't let me repeat any keys, even if they do not have special characters. I have been using Yosemite on my early 2011 MBP for a while now and this has never occurred before. Did I do some strange keyboard combination? And is there a way to turn it off, to get proper key repeats back? I have searched for this everywhere in the settings and online, but apparently it is not a known thing.

Thank you very much in advance!

marked as duplicate by Tetsujin, nohillside Sep 19 '15 at 11:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

To disable the press-and-hold character palette, you could try running the following command in Terminal.app:

defaults write -g ApplePressAndHoldEnabled -bool false

Apps may need to be restarted for changes to take effect.

To reenable the menu, run:

defaults write -g ApplePressAndHoldEnabled -bool true
3
  1. With your MacBook on and running normally, go to the magnifying glass icon on the top right corner of your screen.
  2. Click on the icon and type "Terminal" and hit enter.

  3. You will see a black window with a blinking cursor.

  4. Copy and paste the following command and hit enter.

    defaults write -g ApplePressAndHoldEnabled -bool false

  5. Log out and log in again from the Apple icon on the top left corner, or simply restart your laptop and this will take effect.

  6. To reverse this, change the false to true and repeat the process.

Not the answer you're looking for? Browse other questions tagged .