2

I am trying to set up a Macbook running Yosemite 10.10.5 and a PC running Windows XP in order to share some folders on my home network. Briefly summarizing, I have defined a constant IP they will use to connect themselves to the network. Then, the shared folders have been set up: on Mac OS, using the Preferences > Sharing board and on Windows through the Properties > Sharing > Advanced Sharing menu. All works fine when I request a connection from the Macbook to the PC: I use Finder > Connect to a Server, filling the blank line with smb://IP_OF_THE_PC and then inserting the username and the password of the account that is sharing these data. On the contrary, doing the inverse procedure, I mean requesting a connection from the PC to the Macbook - launching the command \\IP_OF_THE_MAC from the Start menu, the configuration seems to not work. Sincerely, I am a bit surprised because the same configuration was fine when I was running Mavericks 10.9 and so I suppose that all this is due to some modification introduced by Yosemite itself. In the end, can someone suggest me other parameters I should check and/or edit to allow the right functioning of all this?

0

Releasing Mac OS X Yosemite, Apple has updated the SMB protocol to version 3, as documented here. Windows XP, on his side, works almost certainly with the SMB 1 protocol, because the upgrade to version 2 has been done on Windows Vista, as mentioned here. The backward compatibility allows SMB 3 to connect to previous versions, but not viceversa. This issue can be solved using Samba, a free and open source implementation of the SMB protocol that assures full compatibility between different operative systems. It is possible to install and manage Samba on Mac OS installing SMBUp.

0

Recently I came across this problem whilst trying to migrate an old Windows XP machine to a virtual machine under macOS 10.11 VMWare Fusion 8. The Windows machine "pushes" data to the Mac server using SMB.

A bit of searching found this Q&A, but a little more found that this is actually caused by the default authentication level required by macOS changing along with the SMB version.

There is no need to install any additional software, this can be fixed by creating a property list file in /Library/Preferences/ called com.apple.GSS.NTLM.plist.

The contents of the file should be:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" 
"http://www.apple.com/DTDs/PropertyList-1.0.dtd"> 
<plist version="1.0"> 
  <dict> 
    <key>NTLMv1</key>
    <true/> 
    <key>NTLMv2</key>
    <true/> 
  </dict> 
</plist>

Note, this is allowing SMB 1 (and 2) authentication on your Mac so you are effectively reducing the security of your computer by doing this.

You may have to Stop and Start Sharing for this preference to take effect.

The credit for this fix goes to "Allan", see the uk.comp.sys.mac newsgroup post "ntlmv1 authentication on Yosemite desktop share" from October 2014.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .