2

The title pretty much sums it up. I just updated to the new OS X Server (5.0.3) today and when I try to go to localhost, 127.0.0.1, I am getting connection refused. When I load into OS X Server program, and go to the tab on the left Websites, it says Server website on port 80

Not reachable, this website is not available over the Internet

The same goes for port 443. I ran curl, telnet and these ports are indeed closed.

How can I enable these ports again? I can't find where to do it.

Not sure if it matters but I also updated Xcode, and Command line tools today as well.

  • The webserver is running under the root user ?? – Rene Larsen Sep 17 '15 at 21:13
  • @ReneLarsen I don't think so. But how could I tell? – Bob Sep 17 '15 at 21:23
  • If you want port 80 and 443 to be used, then you have to start the web server under the root user - the reason for this is that ports under 1024 are blocked on UNIX/Linix of security reasons. – Rene Larsen Sep 17 '15 at 22:52
  • How do you start the web server under the root user? – user147257 Sep 17 '15 at 23:01
  • 1
    @ReneLarsen No - server.app takes care of all the permissions. You absolutely don't want to do anything like enabling root with Server v5. – bmike Sep 17 '15 at 23:14
1

I haven't seen similar and I have server 5.0.3 running on both 10.11 and 10.10 and those ports are open with no changes needed by me.

I would start with checking your Access for defaults on the server level and perhaps making a change to see if it propagates.

enter image description here

Then check the particular service that is running. port 80/443 can be opened for Profile Manager, Xcode, Wiki or Web Server so you might want to check them all before going to the logs to look and see if there is an error message.

  • I did try enabling both web server and xcode, but still no luck. Then I tried adding custom access under the Access tab, and it would only allow for 'private networks' if I remember right, not 'all networks', and this didn't work for me either. – Bob Sep 17 '15 at 23:52
1

I tried many things including bmike's suggestions but to no avail, so in the end here are the steps I took.

  1. backed up contents of Webserver
  2. deleted Server app
  3. deleted contents of /Library/Server
  4. re-installed Server

And its working again.

1

I upgraded to 5.0.4 and that fixed the issue.

  • They are moving rapidly with the server fixes. Seems you found a bug – bmike Sep 21 '15 at 21:48
0

A restart fixed it for me. We are moving into WindowsLand here.

  • Ugh - server restarts aren't my favorite. – bmike Sep 18 '15 at 1:52
0

A system restart fixed it for me as well.

0

This solved the issue for me.

My server is behind my cable modem and Cisco Router. After I tried all the other suggestions from a variety of sources, I made sure the correct ports were open to my server in the router then turned off the router and cable modem for about one minute.

I rebooted the cable modem... waited about a minute for it to sync back up to the network... then powered up my router. After the router completely booted up and settled down. All the connectivity indicators in the Websites section glowed green.

All Green After Modem and Router Power Cycle.

Don't forget to disable "Filter Internet NAT Redirection" in your modem if you want to be able to get to your in-house hosted website using the domain name URL, not just the local server IP address.

enter image description here

  • The OP states that he fixed it by reinstalling the Server app. OP also states that there was no response to 127.0.0.1 (the local loopback address) which is internal to the Mac IP stack, and for which the modem and router have no bearing. – IconDaemon Jan 22 '17 at 20:17
-3

Best answer would be to move away from $20 products.

Not to be too snarky though, because I too came here looking for the fix to something that "just works."

10.10.5 with Server 5.04 upgrade. Was working fine under 5.03.

Not down with the whole "torch it and start again" abundance of answers, thus the snark.

  • Welcome to Ask Different. You've posted this as an answer, which is only for things that directly answer the question asked. If you have a different question, feel free to ask it using the Ask Question button at the top right. – bmike Sep 23 '15 at 23:45
  • Also, are you saying $20 is too low to too high. OS X is free and server rides on those free coat tails. Server just makes a gui and repackages many open source tools. Could you elaborate on your point with specifics? – bmike Sep 23 '15 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .