I am trying to make my own iOS applications by using Xcode 7 and iOS 9.0. I have successfully been able to install the app on my own iPod by following Xcode 7 develop for iOS without developer account however when I run the application I get this error:

Untrusted Developer Your device management settings do not allow using apps from developer iPhone Developer on this iPod. You can allow using these apps in Settings.

I had a quick look in the Settings app but cannot find a way to allow this application that I made. How would I 'trust' this application running iOS 9?


6 Answers 6


Enterprise and other certificates have to be manually trusted on iOS 9 when they didn't have to on iOS 8 and earlier.

On iOS 9 (and maybe others):

  • Open the Settings app
  • Open General
  • Open Profiles (you won’t see this until after the first profile is installed on an iOS device)
  • Choose the affected profile and trust it

On iOS 15.7 (and maybe others):

  • Open the Settings app
  • Open General
  • Open VPN & Device Management
  • Choose the affected profile and trust it

If you don't see "Profiles & Device Management" then your device needs to reinstall the app or get the appropriate profile from MDM / other enrollment. Also, if your network or system blocks any outbound traffic to Apple servers for time sync, OCSP/CRL or notarization checks, you will see errors or potentially have other challenges to run apps.

  • 1
    In my case it just needed network connection to verify the developer (i.e me). Just turned on WiFi and it started working.
    – GoodSp33d
    Commented Oct 17, 2015 at 12:05
  • 1
    To elaborate on: If you don't see "Profiles & Device Management" - You need to click to install one of your enterprise apps and when the dialogue box appears stating that the app is from an untrusted source click "Cancel". The act of doing this adds the menu item. See here: developer.apple.com/library/ios/documentation/IDEs/Conceptual/… under Manually Trusting an Enterprise Developer. If the dialogue says Done/Retry instead of Cancel, reboot your phone to clear cache.
    – elMarquis
    Commented May 23, 2016 at 11:09
  • In 15.4.1 "Profiles & Device Management" is called VPN & Device Management
    – Burnash
    Commented Jun 2, 2022 at 11:08

On later versions (ios 14.4 and xcode 12.4) I've fixed with the following

  • Open the Settings app
  • Open General
  • Open Device Management
  • Click on Apple Develpment

From here you should be able to trust the app. :-)


Alternative way to fix this error:

  • Open Xcode app on your Mac
  • Navigate to Window > Devices
  • Right click on your device > "Show Provisioning Profiles..." > and delete the profiles
  • Delete the installed app on your device
  • Now rebuild and install the app again

Note: In my case only "Settings > "General" > "Profiles" was shown instead of "Profiles & Device Management", and these steps solved the issue.

  • This is the only thing that worked for me. Commented Aug 20, 2021 at 12:08

There's a also Xcode solution for this problem.

  1. Open Xcode app on your Mac.
  2. Navigate to Window > Devices
  3. Select your device and delete the profiles.
  4. Delete the installed app on your device.
  5. Now rebuild the certificate and install the app again.


  • Please post the information and not just the link. We cannot guarantee the link will last forever.
    – iProgram
    Commented Mar 7, 2016 at 22:08

On iPad or iPhone using iOS 15.4.1:

  • Select your device and build the project using XCode to the target device. "You will get the error here."
  • After that open Settings.
  • Find General.
  • Seek VPN & Device Management section and open it.
  • Click your iCloud account and trust it.

Might be a bit late, but to anyone still searching for a solution to this problem, I finally fixed it by turning on automatic date & time settings on the iPhone.

On your iPhone: Go to Settings  > General > Date & Time. Then turn off and on again the "Set Automatically" setting.

For somme absurd and unknown reason that seemed to solve the problem, for me at least. Hope it helps.

Note: I have an iPhone 7 with iOS 15.6 and i use xCode 13.4.1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .