I am trying to make my own iOS applications by using Xcode 7 and iOS 9.0. I have successfully been able to install the app on my own iPod by following Xcode 7 develop for iOS without developer account however when I run the application I get this error:

Untrusted Developer Your device management settings do not allow using apps from developer iPhone Developer on this iPod. You can allow using these apps in Settings.

I had a quick look in the Aettings app but cannot find a way to allow this application that I made. How would I 'trust' this application running iOS 9?

up vote 48 down vote accepted

Enterprise and other certificates have to be manually trusted on iOS 9 when they didn't have to on iOS 8 and earlier.

  • Open the Settings app
  • Open General
  • Open Profiles & Device Management
  • Choose the affected profile and trust it

If you don't see "Profiles & Device Management" then your device needs to reinstall the app or get the appropriate profile from MDM / other enrollment.

  • 2
    It just appears 'profiles' – iProgram Sep 17 '15 at 20:40
  • Do we know if there is going to be a long term solution to this problem? Or is this it? – DickieBoy Sep 28 '15 at 9:57
  • 1
    @DickieBoy I believe Apple sees this as the long term solution to security. I would plan for this not changing period, but certainly not changing under iOS 9 updates. I would see if your MDM can push the trust profile to devices if you don't want your users to have to tap to manually accept the certificate for enterprise development. – bmike Sep 28 '15 at 10:34
  • 1
    In my case it just needed network connection to verify the developer (i.e me). Just turned on WiFi and it started working. – GoodSp33d Oct 17 '15 at 12:05
  • To elaborate on: If you don't see "Profiles & Device Management" - You need to click to install one of your enterprise apps and when the dialogue box appears stating that the app is from an untrusted source click "Cancel". The act of doing this adds the menu item. See here: developer.apple.com/library/ios/documentation/IDEs/Conceptual/… under Manually Trusting an Enterprise Developer. If the dialogue says Done/Retry instead of Cancel, reboot your phone to clear cache. – elMarquis May 23 '16 at 11:09

For newer versions of iOS >9. Settings->General->Profiles doesn't exist.. You will find the settings you need to change in Settings->General->Device Management.

You can also do the following:

  1. In your iPhone or device, go to Settings
  2. Go to General
  3. Select Profile
  4. Select your user account i.e., developer account
  5. Click on Trust.

This should enable you to test your app on your device.

  • How does this differ from the accepted answer provided two months earlier? – grg Sep 11 '17 at 9:14

Alternative way to fix this error:

  • Open Xcode app on your Mac
  • Navigate to Window > Devices
  • Right click on your device > "Show Provisioning Profiles..." > and delete the profiles
  • Delete the installed app on your device
  • Now rebuild and install the app again

Note: In my case only "Settings > "General" > "Profiles" was shown instead of "Profiles & Device Management", and these steps solved the issue.

Yup, this isn't an extreme issue. No need to contact the dev. You can go to the Settings app and it will be resolved in there. See if this here can help.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Sep 11 '17 at 9:18

There's a also Xcode solution for this problem.

  1. Open Xcode app on your Mac.
  2. Navigate to Window > Devices
  3. Select your device and delete the profiles.
  4. Delete the installed app on your device.
  5. Now rebuild the certificate and install the app again.

http://www.iphonehelping.com/7/how-to-fix-untrusted-enterprise-developer-error-ios-9-1

  • Please post the information and not just the link. We cannot guarantee the link will last forever. – iProgram Mar 7 '16 at 22:08

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.