Ok, so Xcode 4.1 was working fine and I did the incremental update to 4.1.1 at the App Store when it came out a few days ago. Nothing has been stable since that update.

So I found on Stackoverflow to use the command: sudo /Developer/Library/uninstall-devtools --mode=all in uninstall the environment.

It seemed to work as expected. After that, I deleted the remaining empty subfolders in the /Developer folder, emptied the Trash, and rebooted.

At this point I have in every real sense uninstalled and revoved Xcode 4.1.x. So I go back to the App Store to re-download the full current 4.11 package. Yes, I am on Lion. But the Xcode page in the App Store continues to state that I have the package INSTALLED ! And so, does not provide me the ability to re-download it.

Why will the App Store not permit the re-download of a free product in its entirety, as a registered Apple Developer, even if I did have it installed ? Which I don't.

What to do ? Thank you, I am in a bind here. I need to affect some setting on my Mac that will not indicate a false-positive that I have Xcode installed. Ideas ?


3 Answers 3


Check your applications folder for the Xcode 4.1 application installer. This is what the Mac App Store actually downloads and is probably reported as installed. Run that again to reinstall.

  • Janiv, I struggled with this because I went back to my applications folder and checked that there was no installer. I knew I had moved it to a saved folder. So I deleted the installer from there too and nothing changed. App Store continued to say Xcode was installed. Then on a whim I decided to Eject my SuperDuper External drives where I have bootable backups. Viola ! It worked. So apparently, it was finding a copy of the installer on my external drive and that was producing the false-positive. You were right on it, it was just a more crooked road than expected. Hope this may help someone.
    – Ric
    Commented Aug 7, 2011 at 9:34
  • 1
    Excuse me, I have a 65 reputation on stackoverflow. I did not ask to have this question moved over here, so why am I unable to Vote Up and give this a check for Answered because I have Rep of 1 here ? That's pretty bogus !
    – Ric
    Commented Aug 7, 2011 at 9:41
  • Ric, you should still be able to mark this question as answered. No rep is needed for that. And while I didn't move your question, I agree that this is the better forum for it.
    – rahlstrom
    Commented Aug 7, 2011 at 16:43
  • The Answer check kept going green when I clicked it and restoring to grey when I was no longer over it. But I kept going at it and finally it stuck. Thank you for the help. I am not familiar with stackexchange, only overflow so I didn't actually make a choice as to where to post. I best get move educated here. Thx again. Xcode installed.
    – Ric
    Commented Aug 7, 2011 at 18:00

The App Store is pretty aggressive about checking for installed apps. I had similar issues with SuperDuper Clones myself that Mac App Store would find, thus preventing a download/installation/update. See my original question here - Mac App Store updates keep repeating; won't clear

Now that was a while ago and I had since switched to Carbon Copy Cloner, a comparable alternative to SuperDuper, and haven't had any issues since. To make it sweeter, it's free. I am using it with Lion, no problems. It has in fact been explicitly updated for Lion, so don't let that concern you.

It's unfortunate that SuperDuper is still causing these issues. I had assumed Lion or a SuperDuper update would've fixed it by now, but I guess not.


Mac App Store tip:

If an app isn't installed but Mac OS X thinks it is, open the app's page in the Mac App Store app and then Option + Click the app icon.

You should see the price listed, and then a few moments later, the price should change to 'Install'.

aside to @HandyRandy:

I don't understand why SuperDuper would cause this issue but CCC wouldn't.

(Also, SuperDuper is free unless you want some specific advanced features.)

The problem stems from the fact that the Mac App Store is seeing applications on an external drive. Whether that drive was cloned using CCC or SD should make no difference.

Since the Mac App Store will only install applications to /Applications/ it seems to me that it should only consider an app "installed" if it is present in /Applications/ and its current behavior should be considered a Mac App Store bug, not a reflection on any 3rd party software.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .