1

The "Command Line Tools (OS X 10.10) for Xcode 7.0" is not working correctly. It installs and shows in the "Updates Installed" section, however it is still listed in the "Updates Available" section. Oddly, it's being shown in the "Updates Installed" sections multiple times -- once for each time I tried to install it.

I have restarted and it persists. How can I fix this?

screenshot

2 Answers 2

1

I'd go for the standard toolkit first...

  • In Disk Utility, "Verify Disk Permissions" and if necessary "Fix Disk Permissions". Also "Verify Disk" and if necessary "Repair Disk".

  • Reset Home folder permissions & ACLs using OnyX - Maintenance tab/permissions, tick the box at the top then Execute.

  • Update to 10.10.5 [or re-apply if already updated] using the 10.10.5 combo update, not the delta from App Store

4
  • I repaired permissions and installed the update again and it finally went away from the Available list. Now, it's listed 5 times in "Installed Updates" oh well. Did not use OnyX or combo update.
    – Andy
    Commented Sep 17, 2015 at 21:30
  • 1
    The 'toolkit' is really to do all 3 ;)
    – Tetsujin
    Commented Sep 18, 2015 at 4:33
  • @Tetsujin, could you add some detail to your answer about how to "update permissions"? A link would be fine.
    – jwfearn
    Commented Sep 18, 2015 at 18:59
  • 1
    @Tetsujin, I took the liberty of adding a little detail to your answer. I hope you don't mind.
    – jwfearn
    Commented Sep 18, 2015 at 19:05
0

I had the same problem. What ultimately worked for me was switching to a different WiFi network. Not sure why that worked but if you're still stuck, it's worth a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .