3

I have a Mac Mini (late 2012) running the currently latest osx, El Capitan, and as display I use a Dell U2713H connected via thunderbolt (to a DisplayPort on monitor). This configuration is needed to get the maximum output resolution of the monitor, but it seems like it disables the volume control somehow.

When accessing the Sound panel of the system settings, it has disabled the Sound off/mute button in the bottom, and on the Output tab it says (in Norwegian): The selected device has no output controls. And the volume control (on keyboard) doesn't do a thing, neither for the 'global' volume or when playing stuff in iTunes.

My actual audio output is connected through the monitor through to a set of external speakers. The reason for this connection is that I also use the monitor as TV display by utilising the HDMI port on the monitor.

Do you have any suggestion on how to re-enable the volume control with this configuration, if at all possible? Or any alternate solution to enable be listening to sound (not simultaneously) from both the Mac mini and the TV with only one set of speakers (no dual input available on the speakers).

1

HDMI, DisplayPort and Thunderbolt carry a fixed volume digital audio signal so the external device controls the volume. In the future Apple may implement HDMI-CEC which would allow your computer to control the external device volume via software, similarly some devices have drivers which allow them to do the same.

In the meantime, here's a workaround:

  • Install SoundFlower
  • Download SoundFlowerBed, copy to /Applications and run.
  • SoundFlowerBed menu item -> under SoundFlower (2ch) set output to HDMI.
  • System Preferences -> Sound -> select SoundFlower (2ch) as Output device.
  • System Preferences -> Users & Groups -> Login Items -> Add SoundFlowerBed.

Now you have two volume controls: HDMI display volume control and via software on your mac. With this setup your mac is digitally resampling the output and so Mac 100% volume + display 50% volume will likely sound better than Mac 50% volume + display 100% volume.

  • This does work to some extent, but need to be reconfigured after a few hours as Soundflowerbed loose synchronisation (or something like that) – holroy May 31 '18 at 6:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .