1

I am trying to prevent the system to always ask for the password when it wakes up from sleep.

  • I have a MacbookPro with Yosemite 10.10.5.
  • User has admin rights and password different than the iCloud one.
  • FileVault is off.

The System Preferences > Security and Privacy > "Require password [5 seconds] after sleep or screen saver begins" is disabled and there's no way to enable it.

If I execute defaults read com.apple.screensaver i get:

{
    askForPassword = 0;
}

If I execute defaults -currentHost write com.apple.screensaver askForPasswordDelay -int 3600 the defaults don't change...

  • Are you using your own Mac or a company supplied Mac? That the option is disabled suggests a managed default is in place. – Graham Miln Sep 17 '15 at 11:45
  • It's my own Mac :( – mircealungu Sep 20 '15 at 22:10
  • In the same time, if I create a new user, for that one I can access the option. So there's something about this user that is messed up... – mircealungu Sep 20 '15 at 22:10
1

Run on terminal.app;

Admin@MacBook. script bash. #!/bin/sh bash. defaults write com.apple.screensaver askForPassword -bool false

  • defaults write com.apple.screensaver askForPassword -bool false removed the grey out option and allowed me to change the settings. thank you – Kevin Apr 28 '18 at 9:55
  • 2
    Does this require a reboot? Hasn't seemed to change anything for me. – tremby Nov 6 '18 at 17:14

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .